aboutsummaryrefslogtreecommitdiff
path: root/www/galeon/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/galeon/Makefile')
-rw-r--r--www/galeon/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index b7e3339a23b0..225aac5f9d8e 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= galeon
-PORTVERSION= 2.0.5
-PORTREVISION= 2
+PORTVERSION= 2.0.6
CATEGORIES= www gnome
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME:S/2$//}
@@ -16,7 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME:S/2$//}
MAINTAINER= gnome@FreeBSD.org
COMMENT= A GNOME 2 Web browser based on gecko (the Mozilla rendering engine)
-USE_GECKO= firefox mozilla seamonkey xulrunner
+USE_GECKO= firefox mozilla seamonkey xulrunner firefox3
WRKSRC= ${WRKDIR}/${PORTNAME:S/2$//}-${PORTVERSION:S/a$//}
USE_BZIP2= yes
INSTALLS_OMF= yes
@@ -25,8 +24,7 @@ USE_GNOME= gnomeprefix intlhack gnomehack libgnomeui desktopfileutils \
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GETTEXT= yes
-CONFIGURE_ARGS= --enable-nautilus-view=no \
- --with-mozilla=${GECKO}
+CONFIGURE_ARGS= --enable-nautilus-view=no
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
@@ -45,6 +43,12 @@ NO_WERROR= yes
CONFIGURE_ARGS+= --disable-werror
.endif
+.if ${GECKO}=="firefox3"
+CONFIGURE_ARGS+= --with-mozilla=firefox
+.else
+CONFIGURE_ARGS+= --with-mozilla=${GECKO}
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
's|-lpthread|${PTHREAD_LIBS}|g'