aboutsummaryrefslogtreecommitdiff
path: root/www/google-appengine/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/google-appengine/Makefile')
-rw-r--r--www/google-appengine/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/www/google-appengine/Makefile b/www/google-appengine/Makefile
index 669830bca5aa..f806bd575d64 100644
--- a/www/google-appengine/Makefile
+++ b/www/google-appengine/Makefile
@@ -14,9 +14,9 @@ COMMENT= Development tools for Google App Engine (SDK)
LICENSE= APACHE20 BSD3CLAUSE GPLv2 LGPL21 MIT MPL11 PSFL
LICENSE_COMB= multi
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=${PYTHON_VER}:databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow \
- ${PYTHON_PKGNAMEPREFIX}pycrypto>=2.6:security/py-pycrypto
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=${PYTHON_VER}:databases/py-sqlite3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>=2.6:security/py-pycrypto@${PY_FLAVOR}
NO_BUILD= yes
@@ -40,7 +40,7 @@ GAESCRIPTS= _php_runtime.py _python_runtime.py appcfg.py \
gen_protorpc.py php_cli.py remote_api_shell.py \
run_tests.py wrapper_util.py
-MYSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.3:databases/py-MySQLdb
+MYSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.3:databases/py-MySQLdb@${PY_FLAVOR}
PHP_USE= mysql=server
PHP_VARS= gaedatadir+=php want_mysql_ver=55