aboutsummaryrefslogtreecommitdiff
path: root/www/grails/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/grails/Makefile')
-rw-r--r--www/grails/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/www/grails/Makefile b/www/grails/Makefile
index 41ea3a8e54e5..bdcb5cabd978 100644
--- a/www/grails/Makefile
+++ b/www/grails/Makefile
@@ -21,9 +21,9 @@ DATAFILES= LICENSE README build.gradle build.properties gradle.properties \
gradlew conf dist gradle lib media plugins scripts src
SCRIPTFILES= grails grails-debug startGrails
-.if !defined(NOPORTDOCS)
+OPTIONS_DEFINE= DOCS
+
PORTDOCS= api guide index.html css img ref
-.endif
PLIST_FILES= ${SCRIPTFILES:S,^,bin/,} \
${SCRIPTFILES:S,^,${DATADIR:S,${PREFIX}/,,}/bin/,}
PLIST_DIRS= ${DATADIR:S,${PREFIX}/,,}/bin
@@ -44,13 +44,11 @@ do-install:
@${LN} -fs ${DATADIR}/bin/${file} ${STAGEDIR}${PREFIX}/bin/${file}
.endfor
@${ECHO_MSG} " [ DONE ]"
-.if !defined(NOPORTDOCS)
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
@cd ${WRKSRC}/doc \
&& ${FIND} . -type d -exec ${MKDIR} ${STAGEDIR}${DOCSDIR}/{} \; \
&& ${FIND} . -type f -exec ${INSTALL_DATA} {} ${STAGEDIR}${DOCSDIR}/{} \;
@${ECHO_MSG} " [ DONE ]"
-.endif
post-install:
@${FIND} -s ${DATAFILES:S,^,${WRKSRC}/,} -not -type d 2>/dev/null | \