aboutsummaryrefslogtreecommitdiff
path: root/www/horde-base/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/horde-base/Makefile')
-rw-r--r--www/horde-base/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/www/horde-base/Makefile b/www/horde-base/Makefile
index 5bb0ef687a42..489d0c74b547 100644
--- a/www/horde-base/Makefile
+++ b/www/horde-base/Makefile
@@ -334,6 +334,13 @@ pre-install:
${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
.endif
+ # Copy RCSID tag from conf.xml into conf.php to stop Horde complaining
+ @if ! ${GREP} -q -e "$$Horde.*conf\.xml" ${WRKSRC}/config/conf.php.dist; then \
+ ${GREP} -h "$$Horde.*conf\.xml" ${WRKSRC} ${WRKSRC}/config/conf.xml \
+ | ${SED} -e 's#^ *<!--#//#' -e 's# *--> *$$##g' \
+ >> ${WRKSRC}/config/conf.php.dist; \
+ fi
+
do-install:
@${MKDIR} ${HORDEDIR}
.for REP in ${SUB_DIRS}