aboutsummaryrefslogtreecommitdiff
path: root/www/horde4-base
diff options
context:
space:
mode:
Diffstat (limited to 'www/horde4-base')
-rw-r--r--www/horde4-base/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/www/horde4-base/Makefile b/www/horde4-base/Makefile
index f3ca3a8c2046..67d862090756 100644
--- a/www/horde4-base/Makefile
+++ b/www/horde4-base/Makefile
@@ -312,10 +312,10 @@ pre-configure:
pre-install:
.if !defined(WITHOUT_SUPPORTED_DB) && exists(${LOCALBASE}/bin/php)
- @if ! php -m | ${GREP} -q -e "mysql" ; then \
- if ! php -m | ${GREP} -q -e "pgsql" ; then \
- if ! php -m | ${GREP} -q -e "sybase" ; then \
- if ! php -m | ${GREP} -q -e "SQLite" ; then \
+ @if ! php -m 2>&1 | ${GREP} -q -e "mysql" ; then \
+ if ! php -m 2>&1 | ${GREP} -q -e "pgsql" ; then \
+ if ! php -m 2>&1 | ${GREP} -q -e "sybase" ; then \
+ if ! php -m 2>&1 | ${GREP} -q -e "SQLite" ; then \
${ECHO_MSG} "" ; \
${ECHO_MSG} "Please configure PHP with a database support." ; \
${ECHO_MSG} "MySQL, PostgreSQL, SQLite and Sybase (CTLIB or DBLIB)" ; \