aboutsummaryrefslogtreecommitdiff
path: root/www/hs-http-client/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/hs-http-client/Makefile')
-rw-r--r--www/hs-http-client/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/www/hs-http-client/Makefile b/www/hs-http-client/Makefile
index aae3287ca05a..6c9df9b0a8d6 100644
--- a/www/hs-http-client/Makefile
+++ b/www/hs-http-client/Makefile
@@ -1,19 +1,20 @@
# $FreeBSD$
PORTNAME= http-client
-PORTVERSION= 0.3.6.1
-PORTREVISION= 1
+PORTVERSION= 0.4.20
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
-COMMENT= HTTP client engine
+COMMENT= HTTP client engine, intended as a base layer for more user-friendly packages
LICENSE= MIT
USE_CABAL= base64-bytestring>=1.0 blaze-builder>=0.3 case-insensitive>=1.0 \
cookie data-default-class exceptions>=0.4 http-types>=0.8 \
- mime-types network>=2.3 publicsuffixlist random \
+ mime-types network>=2.6 network-uri>=2.6 random \
streaming-commons>=0.1.0.2 text>=0.11
+FLAGS_ENABLE= network-uri
+
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>