aboutsummaryrefslogtreecommitdiff
path: root/www/hs-http-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/hs-http-server/Makefile')
-rw-r--r--www/hs-http-server/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/www/hs-http-server/Makefile b/www/hs-http-server/Makefile
index 36f1b05cecb4..1fd31b3e6a8c 100644
--- a/www/hs-http-server/Makefile
+++ b/www/hs-http-server/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: hs-http-server
-# Date created: December 20 2009
-# Whom: Giuseppe Pilichi aka Jacula Modyun <jacula@gmail.com>
-#
+# Created by: Giuseppe Pilichi aka Jacula Modyun <jacula@gmail.com>
# $FreeBSD$
-#
PORTNAME= http-server
-PORTVERSION= 1
-PORTREVISION= 5
+PORTVERSION= 1.0.1
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
@@ -16,12 +11,17 @@ COMMENT= A library for writing Haskell web servers
LICENSE= BSD
CABAL_SETUP= Setup.hs
-USE_CABAL= HTTP>=4000.0.7 mime>=0.3 network>=2 url>=2 utf8-string>=0.3.4
+USE_CABAL= HTTP>=4000.2.0 mime>=0.3 network>=2 url>=2 utf8-string>=0.3.4
INSTALL_PORTEXAMPLES= cd ${WRKSRC}/example && \
${COPYTREE_SHARE} \* ${EXAMPLESDIR}
-.if !defined(NOPORTEXAMPLES)
+OPTIONS_DEFINE= EXAMPLES
+OPTIONS_DEFAULT= EXAMPLES
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
+
+.if ${PORT_OPTIONS:MEXAMPLES}
SUB_FILES= pkg-message
SHOW_PKGMSG= yes
.endif