aboutsummaryrefslogtreecommitdiff
path: root/www/hs-yesod-platform/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/hs-yesod-platform/Makefile')
-rw-r--r--www/hs-yesod-platform/Makefile168
1 files changed, 118 insertions, 50 deletions
diff --git a/www/hs-yesod-platform/Makefile b/www/hs-yesod-platform/Makefile
index 703d389a92ee..84a7168c1b04 100644
--- a/www/hs-yesod-platform/Makefile
+++ b/www/hs-yesod-platform/Makefile
@@ -1,12 +1,7 @@
-# New ports collection makefile for: hs-yesod-platform
-# Date created: June 10, 2012
-# Whom: haskell@FreeBSD.org
-#
# $FreeBSD$
-#
PORTNAME= yesod-platform
-PORTVERSION= 1.0.5
+PORTVERSION= 1.1.5
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
@@ -14,50 +9,123 @@ COMMENT= Meta package for Yesod
LICENSE= MIT
-USE_CABAL= aeson==0.6.0.2_1 ansi-terminal==0.5.5_4 asn1-data==0.6.1.3_1 \
- attoparsec==0.10.2.0_1 attoparsec-conduit==0.4.0.1_1 \
- attoparsec-enumerator==0.3_2 authenticate==1.2.1.1_1 \
- base-unicode-symbols==0.2.2.3_2 base64-bytestring==0.1.2.0 \
- blaze-builder==0.3.1.0_2 blaze-builder-conduit==0.4.0.2_1 \
- blaze-html==0.5.0.0 blaze-markup==0.5.1.0_1 byteorder==1.0.3_2 \
- case-insensitive==0.4.0.1_2 cereal==0.3.5.2 certificate==1.2.3_1 \
- clientsession==0.7.5_1 conduit==0.4.2_1 cookie==0.4.0_1 \
- cprng-aes==0.2.3_2 cpu==0.1.1 crypto-api==0.10.2_1 \
- crypto-conduit==0.3.2_1 crypto-pubkey-types==0.1.1_1 \
- cryptocipher==0.3.5 cryptohash==0.7.5_1 css-text==0.1.1_2 \
- data-default==0.4.0_1 dlist==0.5_6 email-validate==0.2.8_1 \
- entropy==0.2.1_2 enumerator==0.4.19_1 failure==0.2.0.1_1 \
- fast-logger==0.0.2_2 file-embed==0.0.4.4_1 filesystem-conduit==0.4.0_1 \
- hamlet==1.0.1.4 hashable==1.1.2.3_1 hjsmin==0.1.2_1 hspec==1.2.0.1 \
- html-conduit==0.0.1_1 http-conduit==1.4.1.10 http-date==0.0.2_1 \
- http-types==0.6.11_1 HUnit==1.2.4.2_2 hxt==9.2.2_1 \
- hxt-charproperties==9.1.1_2 hxt-regex-xmlschema==9.0.4_2 \
- hxt-unicode==9.0.2_2 language-javascript==0.5.4_1 largeword==1.0.1_2 \
- lifted-base==0.1.1_1 mime-mail==0.4.1.1_2 monad-control==0.3.1.3_1 \
- network-conduit==0.4.0.1_1 path-pieces==0.1.1_1 pem==0.1.1_1 \
- persistent==0.9.0.4_1 persistent-template==0.9.0.2_1 \
- pool-conduit==0.1.0.2_1 primitive==0.4.1_2 pureMD5==2.1.0.3_2 \
- pwstore-fast==2.2_2 QuickCheck==2.4.2_1 ranges==0.2.4_2 \
- regex-compat==0.95.1_2 resource-pool==0.2.1.0_1 resourcet==0.3.3.1 \
- safe==0.3.3_2 semigroups==0.8.3.2_1 SHA==1.5.0.1_1 \
- shakespeare==1.0.0.2_1 shakespeare-css==1.0.1.2_1 \
- shakespeare-i18n==1.0.0.2_1 shakespeare-js==1.0.0.3_1 \
- shakespeare-text==1.0.0.2_1 silently==1.2.0.2 \
- simple-sendfile==0.2.4 skein==0.1.0.7_1 socks==0.4.1_1 \
- stm==2.3_1 stringsearch==0.3.6.3_2 system-fileio==0.3.8 \
- system-filepath==0.4.6_1 tagged==0.4.2.1_1 tagsoup==0.12.6_2 \
- tagstream-conduit==0.3.2_1 tls==0.9.5_1 tls-extra==0.4.6_1 \
- transformers-base==0.4.1_2 unix-compat==0.3.0.1_1 \
- unordered-containers==0.2.1.0_1 utf8-light==0.4.0.1_1 \
- utf8-string==0.3.7_2 vault==0.2.0.0_1 vector==0.9.1_2 void==0.5.6 \
- wai==1.2.0.3 wai-app-static==1.2.0.4 wai-extra==1.2.0.5 \
- wai-logger==0.1.4_1 wai-test==1.2.0.2_1 warp==1.2.2 \
- xml-conduit==0.7.0.3_1 xml-types==0.3.2 xml2html==0.1.2.3_1 \
- xss-sanitize==0.3.2_1 yaml==0.7.0.3 yesod==1.0.1.6_1 \
- yesod-auth==1.0.2.1_1 yesod-core==1.0.1.2_1 yesod-default==1.0.1.1_1 \
- yesod-form==1.0.0.4_1 yesod-json==1.0.0.1_1 yesod-persistent==1.0.0.1_1 \
- yesod-routes==1.0.1.2_1 yesod-static==1.0.0.3_1 yesod-test==0.2.1 \
- zlib==0.5.3.3_1 zlib-bindings==0.1.0.1_1 zlib-conduit==0.4.0.2
+USE_CABAL= aeson==0.6.0.2_2 \
+ ansi-terminal==0.5.5_5 \
+ asn1-data==0.7.1 \
+ attoparsec==0.10.2.0_2 \
+ attoparsec-conduit==0.5.0.3 \
+ authenticate==1.3.2 \
+ base-unicode-symbols==0.2.2.4 \
+ base64-bytestring==1.0.0.0 \
+ blaze-builder==0.3.1.0_3 \
+ blaze-builder-conduit==0.5.0.3 \
+ blaze-html==0.5.1.1 \
+ blaze-markup==0.5.1.2 \
+ byteorder==1.0.3_3 \
+ case-insensitive==0.4.0.3 \
+ cereal==0.3.5.2_1 \
+ certificate==1.3.3 \
+ clientsession==0.8.0.1 \
+ conduit==0.5.5 \
+ cookie==0.4.0.1 \
+ cprng-aes==0.2.4 \
+ cpu==0.1.1_1 \
+ crypto-api==0.10.2_2 \
+ crypto-conduit==0.4.1 \
+ crypto-pubkey-types==0.2.0 \
+ cryptocipher==0.3.6 \
+ cryptohash==0.7.9 \
+ css-text==0.1.1_3 \
+ data-default==0.5.0 \
+ date-cache==0.3.0 \
+ dlist==0.5_7 \
+ email-validate==0.3.2 \
+ entropy==0.2.1_3 \
+ failure==0.2.0.1_2 \
+ fast-logger==0.3.1 \
+ file-embed==0.0.4.6 \
+ filesystem-conduit==0.5.0.2 \
+ hamlet==1.1.1.1 \
+ hashable==1.1.2.5 \
+ hjsmin==0.1.3 \
+ hspec==1.4.2 \
+ hspec-expectations==0.3.0.3 \
+ html-conduit==0.1.0.4 \
+ http-conduit==1.8.4.3 \
+ http-date==0.0.3 \
+ http-types==0.7.3.0.1 \
+ language-javascript==0.5.7 \
+ largeword==1.0.3 \
+ lifted-base==0.2 \
+ mime-mail==0.4.1.2 \
+ mime-types==0.1.0.0 \
+ monad-control==0.3.1.4 \
+ monad-logger==0.2.3 \
+ network-conduit==0.6.1.1 \
+ path-pieces==0.1.2 \
+ pem==0.1.1_2 \
+ persistent==1.0.2.2 \
+ persistent-template==1.0.0.2 \
+ pool-conduit==0.1.0.3 \
+ primitive==0.5.0.1 \
+ pureMD5==2.1.2.1 \
+ pwstore-fast==2.3 \
+ ranges==0.2.4_3 \
+ resource-pool==0.2.1.1 \
+ resourcet==0.4.4 \
+ safe==0.3.3_3 \
+ semigroups==0.8.4.1 \
+ SHA==1.6.1 \
+ shakespeare==1.0.2 \
+ shakespeare-css==1.0.2 \
+ shakespeare-i18n==1.0.0.2_2 \
+ shakespeare-js==1.1.0 \
+ shakespeare-text==1.0.0.5 \
+ silently==1.2.4 \
+ simple-sendfile==0.2.8 \
+ skein==0.1.0.10 \
+ socks==0.4.2 \
+ stringsearch==0.3.6.4 \
+ system-fileio==0.3.10 \
+ system-filepath==0.4.7 \
+ tagged==0.4.4 \
+ tagsoup==0.12.8 \
+ tagstream-conduit==0.5.3 \
+ tar==0.4.0.1 \
+ tls==1.0.2 \
+ tls-extra==0.5.0 \
+ transformers-base==0.4.1_3 \
+ unix-compat==0.4.0.0 \
+ unordered-containers==0.2.2.1 \
+ utf8-light==0.4.0.1_2 \
+ utf8-string==0.3.7_3 \
+ vault==0.2.0.1 \
+ vector==0.10.0.1 \
+ void==0.5.8 \
+ wai==1.3.0.1 \
+ wai-app-static==1.3.0.4 \
+ wai-extra==1.3.0.4 \
+ wai-logger==0.3.0 \
+ wai-test==1.3.0 \
+ warp==1.3.5 \
+ xml-conduit==1.0.3.3 \
+ xml-types==0.3.3 \
+ xss-sanitize==0.3.2_2 \
+ yaml==0.8.1.1 \
+ yesod==1.1.4.1 \
+ yesod-auth==1.1.2 \
+ yesod-core==1.1.6.1 \
+ yesod-default==1.1.2 \
+ yesod-form==1.2.0.1 \
+ yesod-json==1.1.2 \
+ yesod-persistent==1.1.0 \
+ yesod-routes==1.1.1.1 \
+ yesod-static==1.1.1.1 \
+ yesod-test==0.3.1.1 \
+ zlib-bindings==0.1.1.2 \
+ zlib-conduit==0.5.0.3
+
+IGNORE_DYNAMIC= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>