aboutsummaryrefslogtreecommitdiff
path: root/www/http-analyze/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/http-analyze/Makefile')
-rw-r--r--www/http-analyze/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/www/http-analyze/Makefile b/www/http-analyze/Makefile
index 3671a1e38a97..da3fd6eedc9c 100644
--- a/www/http-analyze/Makefile
+++ b/www/http-analyze/Makefile
@@ -8,18 +8,21 @@ PORTNAME= http-analyze
PORTVERSION= 2.01
PORTREVISION= 4
CATEGORIES= www
-MASTER_SITES= ftp://ftp.rent-a-guru.de/pub/http-analyze2.01/
+MASTER_SITES= ftp://ftp.mayn.de/pub/unix/network/www/
DISTNAME= ${PORTNAME}${PORTVERSION}
EXTRACT_SUFX= -src.tar.gz
MAINTAINER= todd@thisisa.com
COMMENT= A fast Log-Analyzer for web servers
-BROKEN= "Attempts to use BUILD_DEPENDS in patch phase"
-
-BUILD_DEPENDS= gif2png:${PORTSDIR}/graphics/gif2png
+PATCH_DEPENDS= gif2png:${PORTSDIR}/graphics/gif2png
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
MAN1= http-analyze.1
+post-patch:
+ @${ECHO_MSG} "Converting GIFs to PNG format"
+ @${FIND} "${WRKSRC}/files/btn" -name "*.gif" -type f \
+ -exec gif2png -d -O {} \;
+
.include <bsd.port.mk>