aboutsummaryrefslogtreecommitdiff
path: root/www/httpsqs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/httpsqs/Makefile')
-rw-r--r--www/httpsqs/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/www/httpsqs/Makefile b/www/httpsqs/Makefile
new file mode 100644
index 000000000000..543afb1dd9ca
--- /dev/null
+++ b/www/httpsqs/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: httpsqs
+# Date created: 2011-04-22
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= httpsqs
+PORTVERSION= 1.6
+CATEGORIES= www devel
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= lichray@gmail.com
+COMMENT= Simple Queue Service based on HTTP GET/POST protocol
+
+LIB_DEPENDS+= tokyocabinet:${PORTSDIR}/databases/tokyocabinet \
+ event-2.0:${PORTSDIR}/devel/libevent2
+
+BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
+
+MAKE_ENV= LIBS="${PTHREAD_LIBS}"
+
+LICENSE= BSD
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-patch:
+ ${CP} ${PATCHDIR}/Makefile ${WRKSRC}
+ @${REINPLACE_CMD} -e 's|{ 0 }|"${PREFIX}/bin/${PORTNAME}"|' \
+ ${WRKSRC}/httpsqs.c
+
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>