aboutsummaryrefslogtreecommitdiff
path: root/www/instiki
diff options
context:
space:
mode:
Diffstat (limited to 'www/instiki')
-rw-r--r--www/instiki/Makefile38
-rw-r--r--www/instiki/files/bluecloth-patch-lib-chunks-engines-rb12
-rw-r--r--www/instiki/files/instiki.in2
3 files changed, 43 insertions, 9 deletions
diff --git a/www/instiki/Makefile b/www/instiki/Makefile
index 5e6f733c1ff1..8b7eb7ee33c1 100644
--- a/www/instiki/Makefile
+++ b/www/instiki/Makefile
@@ -7,19 +7,17 @@
PORTNAME= instiki
PORTVERSION= 0.11.0
+PORTREVISION= 1
CATEGORIES= www ruby
-MASTER_SITES= http://rubyforge.org/frs/download.php/9296/ \
- http://rubyforge.rubyuser.de/instiki/
+MASTER_SITES= http://rubyforge.rubyuser.de/instiki/
EXTRACT_SUFX= .tgz
-MAINTAINER= arsptr@optusnet.com.au
+MAINTAINER= arsptr@internode.on.net
COMMENT= Easy to set up wiki clone implemented in ruby
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/sqlite3_api.so:${PORTSDIR}/databases/ruby-sqlite3
BUILD_DEPENDS+= ${RUN_DEPENDS} rake:${PORTSDIR}/devel/rubygem-rake
-PATCH_DEPENDS= ${BUILD_DEPENDS}
-NO_BUILD= yes
USE_RUBY= yes
USE_RUBY_FEATURES= 1.8
@@ -34,13 +32,37 @@ SUB_LIST+= INSTIKIDIR=${INSTIKIDIR} \
SUB_FILES+= pkg-deinstall
RUBY_SHEBANG_FILES=instiki
-post-patch:
+OPTIONS= PORT_BLUECLOTH "Use BlueCloth gem from ports" On
+
+do-build:
( cd ${WRKSRC}/db/ && \
rake environment RAILS_ENV=production migrate )
do-install:
${CP} -pR ${WRKSRC}/ ${PREFIX}/${INSTIKIDIR}
- ${CP} ${PREFIX}/${INSTIKIDIR}/db/production.db.sqlite3 ${PREFIX}/${INSTIKIDIR}/db/default.db.sqlite3
+ ${CP} ${PREFIX}/${INSTIKIDIR}/db/production.db.sqlite3 \
+ ${PREFIX}/${INSTIKIDIR}/db/default.db.sqlite3
${CHMOD} +x ${PREFIX}/${INSTIKIDIR}/instiki
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PORT_BLUECLOTH)
+
+# can't include this because it redefines do-install.
+# .include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
+
+# For now, copy and paste the definition of SPEC_DIR from the above
+REV= 1.8
+GEMS_BASE_DIR= lib/ruby/gems/${REV}
+SPEC_DIR= ${GEMS_BASE_DIR}/specifications
+
+RUN_DEPENDS+= ${LOCALBASE}/${SPEC_DIR}/BlueCloth-1.0.0.gemspec:${PORTSDIR}/www/rubygem-bluecloth
+
+EXTRA_PATCHES+= ${FILESDIR}/bluecloth-patch-lib-chunks-engines-rb
+
+post-patch:
+ ${RM} ${WRKSRC}/lib/chunks/engines.rb.orig
+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/instiki/files/bluecloth-patch-lib-chunks-engines-rb b/www/instiki/files/bluecloth-patch-lib-chunks-engines-rb
new file mode 100644
index 000000000000..7be347bfa6a4
--- /dev/null
+++ b/www/instiki/files/bluecloth-patch-lib-chunks-engines-rb
@@ -0,0 +1,12 @@
+--- lib/chunks/engines.rb.orig Sun Mar 12 15:57:24 2006
++++ lib/chunks/engines.rb Tue Jun 6 22:45:16 2006
+@@ -35,7 +35,8 @@
+
+ class Markdown < AbstractEngine
+ def mask
+- require_dependency 'bluecloth_tweaked'
++ require_dependency 'rubygems'
++ require_gem 'BlueCloth'
+ BlueCloth.new(@content, @content.options[:engine_opts]).to_html
+ end
+ end
diff --git a/www/instiki/files/instiki.in b/www/instiki/files/instiki.in
index 645638f61ac1..54dc543be178 100644
--- a/www/instiki/files/instiki.in
+++ b/www/instiki/files/instiki.in
@@ -23,7 +23,7 @@ command_interpreter="%%RUBY_WITH_SUFFIX%%"
: ${instiki_enable="NO"}
: ${instiki_flags="--port %%INSTIKIPORT%% --daemon"}
-sig_stop=-KILL
+sig_stop=KILL
load_rc_config $name