aboutsummaryrefslogtreecommitdiff
path: root/www/instiki
diff options
context:
space:
mode:
Diffstat (limited to 'www/instiki')
-rw-r--r--www/instiki/Makefile20
-rw-r--r--www/instiki/distinfo6
-rw-r--r--www/instiki/pkg-plist15
3 files changed, 16 insertions, 25 deletions
diff --git a/www/instiki/Makefile b/www/instiki/Makefile
index 4d2b4cc5419b..d1bd0fc9751a 100644
--- a/www/instiki/Makefile
+++ b/www/instiki/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= instiki
-PORTVERSION= 0.12.0
+PORTVERSION= 0.13.0
CATEGORIES= www ruby
MASTER_SITES= RF
-DISTNAME= ${PORTNAME}-0.12.0
+#DISTNAME= ${PORTNAME}-0.12.0
EXTRACT_SUFX= .tgz
MAINTAINER= beech@FreeBSD.org
@@ -18,7 +18,6 @@ COMMENT= Easy to set up wiki clone implemented in ruby
LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
BUILD_DEPENDS= rake:${PORTSDIR}/devel/rubygem-rake
-
USE_RUBY= yes
USE_RUBY_FEATURES= 1.8
USE_LDCONFIG= yes
@@ -46,18 +45,8 @@ BUILD_DEPENDS+= ${LOCALBASE}/${SPEC_DIR}/BlueCloth-1.0.0.gemspec:${PORTSDIR}/www
EXTRA_PATCHES+= ${FILESDIR}/bluecloth-patch-lib-chunks-engines-rb
.endif
-pre-fetch:
- @${ECHO_MSG} ""
- @${ECHO_MSG} " ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! !"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " WARNING!"
- @${ECHO_MSG} "If you are updating from a previous version, Hit ^c now"
- @${ECHO_MSG} "and read /usr/ports/UPDATING!"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! !"
-
-post-extract:
- @find -d ${WRKSRC} -type d -name .svn -exec rm -rf {} \;
+post-extract:
+ @${FIND} -d ${WRKSRC} -type d -name .svn -exec ${RM} -rf {} \;
post-patch:
${RM} ${WRKSRC}/lib/chunks/engines.rb.orig
@@ -75,5 +64,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-
.include <bsd.port.post.mk>
diff --git a/www/instiki/distinfo b/www/instiki/distinfo
index dbcdc6439041..7f3963072a2f 100644
--- a/www/instiki/distinfo
+++ b/www/instiki/distinfo
@@ -1,3 +1,3 @@
-MD5 (instiki-0.12.0.tgz) = 41a0aad7b2decddbbe5d1f28958c7119
-SHA256 (instiki-0.12.0.tgz) = 152b2ed678e91ac909ed263ccdb5c82d4966e25a2e60873ce4f0c5a3553100a1
-SIZE (instiki-0.12.0.tgz) = 4493156
+MD5 (instiki-0.13.0.tgz) = 147a8c9ad7e453ba51e5d609cbb769b2
+SHA256 (instiki-0.13.0.tgz) = a241edd50ca9ed1ccd95215b2a25057540b5a19d81e6eb136f902310f9d26896
+SIZE (instiki-0.13.0.tgz) = 4490068
diff --git a/www/instiki/pkg-plist b/www/instiki/pkg-plist
index ef1a317eb7a3..5e26c149fa38 100644
--- a/www/instiki/pkg-plist
+++ b/www/instiki/pkg-plist
@@ -61,6 +61,8 @@
%%DATADIR%%/config/environments/test.rb
%%DATADIR%%/config/routes.rb
%%DATADIR%%/config/spam_patterns.txt
+%%DATADIR%%/db/.DS_Store
+%%DATADIR%%/db/development_structure.sql
%%DATADIR%%/db/migrate/001_beta1_schema.rb
%%DATADIR%%/db/migrate/002_beta2_changes_bulk.rb
%%DATADIR%%/db/default.db.sqlite3
@@ -92,7 +94,7 @@
%%DATADIR%%/lib/url_generator.rb
%%DATADIR%%/lib/wiki_content.rb
%%DATADIR%%/lib/wiki_words.rb
-%%DATADIR%%/log/development.log
+%%DATADIR%%/log/.DS_Store
%%DATADIR%%/log/production.log
%%DATADIR%%/natives/osx/desktop_launcher/AppDelegate.h
%%DATADIR%%/natives/osx/desktop_launcher/AppDelegate.mm
@@ -107,7 +109,6 @@
%%DATADIR%%/natives/osx/desktop_launcher/MakeDMG.sh
%%DATADIR%%/natives/osx/desktop_launcher/main.mm
%%DATADIR%%/natives/osx/desktop_launcher/version.plist
-%%DATADIR%%/public/.DS_Store
%%DATADIR%%/public/.htaccess
%%DATADIR%%/public/404.html
%%DATADIR%%/public/500.html
@@ -172,10 +173,8 @@
%%DATADIR%%/test/unit/wiki_file_test.rb
%%DATADIR%%/test/unit/wiki_words_test.rb
%%DATADIR%%/test/watir/e2e.rb
-%%DATADIR%%/tmp/.DS_Store
-%%DATADIR%%/tmp/cache/.DS_Store
-%%DATADIR%%/tmp/sessions/.DS_Store
%%DATADIR%%/vendor/.DS_Store
+%%DATADIR%%/vendor/plugins/.DS_Store
%%DATADIR%%/vendor/plugins/dnsbl_check/README
%%DATADIR%%/vendor/plugins/dnsbl_check/init.rb
%%DATADIR%%/vendor/plugins/dnsbl_check/lib/dnsbl_check.rb
@@ -227,6 +226,7 @@
%%DATADIR%%/vendor/plugins/rubyzip-0.9.1/test/zipfilesystemtest.rb
%%DATADIR%%/vendor/plugins/rubyzip-0.9.1/test/ziprequiretest.rb
%%DATADIR%%/vendor/plugins/rubyzip-0.9.1/test/ziptest.rb
+%%DATADIR%%/vendor/plugins/sqlite3-ruby/.DS_Store
%%DATADIR%%/vendor/plugins/sqlite3-ruby/sqlite3.rb
%%DATADIR%%/vendor/plugins/sqlite3-ruby/sqlite3/constants.rb
%%DATADIR%%/vendor/plugins/sqlite3-ruby/sqlite3/database.rb
@@ -240,7 +240,6 @@
%%DATADIR%%/vendor/plugins/sqlite3-ruby/sqlite3/translator.rb
%%DATADIR%%/vendor/plugins/sqlite3-ruby/sqlite3/value.rb
%%DATADIR%%/vendor/plugins/sqlite3-ruby/sqlite3/version.rb
-%%DATADIR%%/vendor/rails/.DS_Store
%%DATADIR%%/vendor/rails/actionmailer/CHANGELOG
%%DATADIR%%/vendor/rails/actionmailer/MIT-LICENSE
%%DATADIR%%/vendor/rails/actionmailer/README
@@ -481,6 +480,7 @@
%%DATADIR%%/vendor/rails/actionpack/test/controller/selector_test.rb
%%DATADIR%%/vendor/rails/actionpack/test/controller/send_file_test.rb
%%DATADIR%%/vendor/rails/actionpack/test/controller/session_management_test.rb
+%%DATADIR%%/vendor/rails/actionpack/test/controller/session_fixation_test.rb
%%DATADIR%%/vendor/rails/actionpack/test/controller/test_test.rb
%%DATADIR%%/vendor/rails/actionpack/test/controller/url_rewriter_test.rb
%%DATADIR%%/vendor/rails/actionpack/test/controller/verification_test.rb
@@ -790,6 +790,8 @@
%%DATADIR%%/vendor/rails/activerecord/test/fixtures/bad_fixtures/missing_value
%%DATADIR%%/vendor/rails/activerecord/test/fixtures/binaries.yml
%%DATADIR%%/vendor/rails/activerecord/test/fixtures/binary.rb
+%%DATADIR%%/vendor/rails/activerecord/test/fixtures/book.rb
+%%DATADIR%%/vendor/rails/activerecord/test/fixtures/books.yml
%%DATADIR%%/vendor/rails/activerecord/test/fixtures/categories.yml
%%DATADIR%%/vendor/rails/activerecord/test/fixtures/categories/special_categories.yml
%%DATADIR%%/vendor/rails/activerecord/test/fixtures/categories/subsubdir/arbitrary_filename.yml
@@ -798,6 +800,7 @@
%%DATADIR%%/vendor/rails/activerecord/test/fixtures/categorization.rb
%%DATADIR%%/vendor/rails/activerecord/test/fixtures/categorizations.yml
%%DATADIR%%/vendor/rails/activerecord/test/fixtures/category.rb
+%%DATADIR%%/vendor/rails/activerecord/test/fixtures/citation.rb
%%DATADIR%%/vendor/rails/activerecord/test/fixtures/column_name.rb
%%DATADIR%%/vendor/rails/activerecord/test/fixtures/comment.rb
%%DATADIR%%/vendor/rails/activerecord/test/fixtures/comments.yml