aboutsummaryrefslogtreecommitdiff
path: root/www/kdewebdev/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/kdewebdev/Makefile')
-rw-r--r--www/kdewebdev/Makefile49
1 files changed, 31 insertions, 18 deletions
diff --git a/www/kdewebdev/Makefile b/www/kdewebdev/Makefile
index ef1075e6aa09..3986510fe60b 100644
--- a/www/kdewebdev/Makefile
+++ b/www/kdewebdev/Makefile
@@ -1,17 +1,21 @@
# New ports collection makefile for: Quanta+
-# Date created: 19 May 2000
-# Whom: Will Andrews <will@FreeBSD.org>
+# Date created: 26 Sep 2002
+# Whom: AlanE <alane@freebsd.org>
#
# $FreeBSD$
#
+# NOTE: This is the official release version of quanta which will be
+# included in kde-3.1. Yay!
+
PORTNAME= quanta
-PORTVERSION= 3.0pr2a
-PORTEPOCH= 1
+PORTVERSION= 3.0
+PORTEPOCH= 2 # dammit! I hate this kludge.
CATEGORIES= www kde
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-DIST_SUBDIR= ${PORTNAME}
+
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= alane#/quanta
+DIST_SUBDIR= ${PORTNAME}
.if !defined(NOPORTDOCS)
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
@@ -21,7 +25,7 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
php.tar.bz2
.endif
-MAINTAINER= jeremy@external.org
+MAINTAINER= alane@freebsd.org
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
@@ -31,21 +35,30 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET=
CONFIGURE_ARGS+= --with-extra-includes=${LOCALBASE}/include \
- --disable-closure \
- --enable-threads \
- --disable-debug
+ --disable-closure --enable-threads --disable-debug
USE_GMAKE= yes
DOCS= css html javascript php
+QDOCSDIR= share/apps/quanta/doc
+PLIST_SUB+= QDOCSDIR=${QDOCSDIR} DOCSDIR=${DOCSDIR}
+
+.include <bsd.port.pre.mk>
+
+pre-configure:
+ cd ${WRKSRC}; ${GMAKE} -f Makefile.cvs
+
post-install:
+ ${RM} -fr ${PREFIX}/${QDOCSDIR}
.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/${QDOCSDIR}
.for doc in ${DOCS}
- cd ${WRKDIR}/${doc} && \
- ${CP} -R ${doc} ${doc}.docrc ${PREFIX}/share/apps/quanta/doc
-.endfor
- ${CHOWN} -R root:wheel ${PREFIX}/share/apps/quanta/doc
- find ${PREFIX}/share/apps/quanta/doc -type f | xargs ${CHMOD} 444
-.endif
+ cd ${WRKDIR}/${doc}; ${CP} -R ${doc} ${doc}.docrc ${PREFIX}/${QDOCSDIR}
+.endfor # doc in ${DOCS}
+ ${CHOWN} -R ${DOCOWN}:${DOCGRP} ${PREFIX}/${QDOCSDIR}
+ ${FIND} ${PREFIX}/${QDOCSDIR}|sort|xargs ${CHMOD} ${DOCMODE}
+ ${FIND} ${PREFIX}/${QDOCSDIR} -type d|sort|xargs ${CHMOD} ugo+x
+.endif # !defined(NOPORTDOCS)
+ if ${TEST} -f ${PKGMESSAGE}; then ${CAT} ${PKGMESSAGE}; fi
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>