aboutsummaryrefslogtreecommitdiff
path: root/www/libapreq2/files/patch-glue-perl-Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'www/libapreq2/files/patch-glue-perl-Makefile.PL')
-rw-r--r--www/libapreq2/files/patch-glue-perl-Makefile.PL27
1 files changed, 19 insertions, 8 deletions
diff --git a/www/libapreq2/files/patch-glue-perl-Makefile.PL b/www/libapreq2/files/patch-glue-perl-Makefile.PL
index f8515fd7ec69..f7a8b96c8ce1 100644
--- a/www/libapreq2/files/patch-glue-perl-Makefile.PL
+++ b/www/libapreq2/files/patch-glue-perl-Makefile.PL
@@ -1,13 +1,24 @@
---- glue/perl/Makefile.PL Mon May 2 20:24:29 2005
-+++ glue/perl/Makefile.PL Sat May 21 17:57:39 2005
-@@ -443,8 +443,8 @@
- 'NAME' => '$class',
- 'VERSION' => '$version',
+--- glue/perl/Makefile.PL.orig 2006-08-08 21:26:45.000000000 -0700
++++ glue/perl/Makefile.PL 2007-09-22 20:12:05.000000000 -0700
+@@ -71,2 +71,3 @@
+ $apache_includes .= " $1";
++ $apache_includes =~ s,\|\#_!!_\#\|,,g;
+
+@@ -84,3 +85,3 @@
+ die "Can't find apreq libname";
+- $apreq_libname = $1;
++ $apreq_libname = $1; $apreq_libname =~ s,^\|\#_!!_\#\|,,;
+
+@@ -88,4 +89,3 @@
+ die "Can't find package version";
+- $version = $1;
+-
++ $version = $1; $version =~ s,^\|\#_!!_\#\|,,;
+ }
+@@ -417,4 +417,4 @@
'TYPEMAPS' => [qw(@$mp2_typemaps $typemap)],
- 'INC' => "-I$base_dir/glue/perl/xs -I$inc_dir -I$xs_dir $apache_includes",
- 'LIBS' => "$apreq_libs $apr_libs",
-+ 'INC' => "-I$base_dir/glue/perl/xs -I$inc_dir -I$xs_dir $apache_includes -I\\\$(PREFIX)/%%APACHEINCLUDEDIR%%/modules/perl",
++ 'INC' => "-I$base_dir/glue/perl/xs -I$inc_dir -I$xs_dir $apache_includes -I\\\$(PREFIX)/include/apache2/modules/perl",
+ 'LIBS' => "$apreq_libs $apr_libs -L\\\$(PREFIX)/lib",
} ;
- $txt .= "'depend' => $deps,\n" if ($deps) ;
- $txt .= qq{