aboutsummaryrefslogtreecommitdiff
path: root/www/libsocialweb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/libsocialweb/Makefile')
-rw-r--r--www/libsocialweb/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/www/libsocialweb/Makefile b/www/libsocialweb/Makefile
index 055b138d4461..d88a98859905 100644
--- a/www/libsocialweb/Makefile
+++ b/www/libsocialweb/Makefile
@@ -3,22 +3,28 @@
PORTNAME= libsocialweb
PORTVERSION= 0.25.21
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www gnome
MASTER_SITES= GNOME
MAINTAINER= kwm@FreeBSD.org
-COMMENT= Personal social data server.
+COMMENT= Personal social data server
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= vapigen:${PORTSDIR}/lang/vala
LIB_DEPENDS= librest-0.7.so:${PORTSDIR}/devel/librest \
libgnome-keyring.so:${PORTSDIR}/security/libgnome-keyring \
+ libsoup-gnome-2.4.so:${PORTSDIR}/devel/libsoup-gnome \
libjson-glib-1.0.so:${PORTSDIR}/devel/json-glib
USES= gettext gmake libtool pathfix pkgconfig tar:xz
USE_GNOME= gconf2 glib20 intlhack introspection:build \
libxslt:build
GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-vala-bindings
# review if we want all the services enabled, because of not completely