aboutsummaryrefslogtreecommitdiff
path: root/www/libxul/files/patch-bug786995
diff options
context:
space:
mode:
Diffstat (limited to 'www/libxul/files/patch-bug786995')
-rw-r--r--www/libxul/files/patch-bug78699536
1 files changed, 0 insertions, 36 deletions
diff --git a/www/libxul/files/patch-bug786995 b/www/libxul/files/patch-bug786995
deleted file mode 100644
index 85b3abcc3d13..000000000000
--- a/www/libxul/files/patch-bug786995
+++ /dev/null
@@ -1,36 +0,0 @@
-# Bug 786995 - configure should check for SSSE3 support in the whole toolchain
-
---- configure.in.orig 2012-09-02 00:37:29.000000000 +0200
-+++ configure.in 2012-09-02 00:38:50.000000000 +0200
-@@ -1710,15 +1710,15 @@
- _MOZ_RTTI_FLAGS_OFF=-fno-rtti
-
- # Check for -mssse3 on $CC
-- AC_MSG_CHECKING([for -mssse3 option to $CC])
-- HAVE_COMPILER_FLAG_MSSSE3=
-+ AC_MSG_CHECKING([if toolchain supports -mssse3 option])
-+ HAVE_TOOLCHAIN_SUPPORT_MSSSE3=
- _SAVE_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -mssse3"
-- AC_TRY_COMPILE(,,AC_MSG_RESULT([yes])
-- [HAVE_COMPILER_FLAG_MSSSE3=1],
-+ AC_TRY_COMPILE([asm ("pmaddubsw %xmm2,%xmm3");],,AC_MSG_RESULT([yes])
-+ [HAVE_TOOLCHAIN_SUPPORT_MSSSE3=1],
- AC_MSG_RESULT([no]))
- CFLAGS=$_SAVE_CFLAGS
-- AC_SUBST(HAVE_COMPILER_FLAG_MSSSE3)
-+ AC_SUBST(HAVE_TOOLCHAIN_SUPPORT_MSSSE3)
-
- # Turn on GNU-specific warnings:
- # -Wall - turn on a lot of warnings
---- gfx/skia/Makefile.in.orig 2012-09-02 00:39:00.000000000 +0200
-+++ gfx/skia/Makefile.in 2012-09-02 00:39:21.000000000 +0200
-@@ -365,7 +365,7 @@
- SkUtils_opts_SSE2.cpp \
- opts_check_SSE2.cpp \
- $(NULL)
--ifdef HAVE_COMPILER_FLAG_MSSSE3
-+ifdef HAVE_TOOLCHAIN_SUPPORT_MSSSE3
- DEFINES += -DSK_BUILD_SSSE3
- CPPSRCS += SkBitmapProcState_opts_SSSE3.cpp
- endif