aboutsummaryrefslogtreecommitdiff
path: root/www/linux-c7-qtwebkit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/linux-c7-qtwebkit/Makefile')
-rw-r--r--www/linux-c7-qtwebkit/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/www/linux-c7-qtwebkit/Makefile b/www/linux-c7-qtwebkit/Makefile
new file mode 100644
index 000000000000..250d1d26465e
--- /dev/null
+++ b/www/linux-c7-qtwebkit/Makefile
@@ -0,0 +1,23 @@
+# Created by: Piotr Kubaj <pkubaj@anongoth.pl>
+# $FreeBSD$
+
+PORTNAME= qtwebkit
+PORTVERSION= 2.3.4
+CATEGORIES= www linux
+MASTER_SITES= EPEL7/q
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= RPM of QtWebkit (Linux CentOS ${LINUX_DIST_VER})
+
+CONFLICTS= linux-c6-qt47-webkit-[0-9]*
+
+ONLY_FOR_ARCHS= amd64
+RPMVERSION= 6.el7
+USES= linux:c7
+USE_LDCONFIG= yes
+USE_LINUX= fontconfig png xorglibs sqlite3 qt qt-x11
+USE_LINUX_RPM= yes
+
+DESCR= ${.CURDIR}/../webkit-gtk3/pkg-descr # contains no GTK references, reuse
+
+.include <bsd.port.mk>