aboutsummaryrefslogtreecommitdiff
path: root/www/linux-mplayer-plugin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/linux-mplayer-plugin/Makefile')
-rw-r--r--www/linux-mplayer-plugin/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/www/linux-mplayer-plugin/Makefile b/www/linux-mplayer-plugin/Makefile
index 79d5ab8d6a5c..08088bdfedd5 100644
--- a/www/linux-mplayer-plugin/Makefile
+++ b/www/linux-mplayer-plugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mplayerplug-in
PORTVERSION= 3.55
-PORTREVISION= 3
+PORTREVISION= 4
DISTVERSIONSUFFIX= -1.rh9.rf
CATEGORIES= www multimedia
MASTER_SITES= CENKES http://apt.sw.be/packages/mplayerplug-in/ \
@@ -15,18 +15,21 @@ COMMENT= Embed MPlayer into browser
RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
+USES= webplugin:linux
NO_BUILD= yes
USE_LINUX_RPM= yes
USE_LINUX_APPS= atk gtk2 pango xorglibs
PREFIX?= ${LOCALBASE}
SRC_DISTFILES=
DIST_SUBDIR= rpm
-
-USE_NPAPI= linux
-NPAPI_WRKSRC= ${WRKDIR}/usr/lib/mozilla/plugins
-NPAPI_FILES= ${PLUGINS_EXT:S/^/${PORTNAME}/}
+WEBPLUGIN_NAME= #
+WEBPLUGIN_FILES= ${PLUGINS_EXT:S/^/${PORTNAME}/}
PLUGINS_EXT= .so .xpt -dvx.so -dvx.xpt -qt.so -qt.xpt -rm.so -rm.xpt -wmp.so -wmp.xpt
+PLIST_FILES+= ${PLUGINS_EXT:S,^,lib/browser_plugins/${PORTNAME},}
+PLIST_DIRSTRY= lib/browser_plugins
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${WEBPLUGIN_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/usr/lib/mozilla/plugins/* ${STAGEDIR}${WEBPLUGIN_DIR}
-NO_STAGE= yes
-.include "${.CURDIR}/Makefile.npapi"
.include <bsd.port.mk>