aboutsummaryrefslogtreecommitdiff
path: root/www/linux-opera-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/linux-opera-devel/Makefile')
-rw-r--r--www/linux-opera-devel/Makefile97
1 files changed, 0 insertions, 97 deletions
diff --git a/www/linux-opera-devel/Makefile b/www/linux-opera-devel/Makefile
deleted file mode 100644
index f6eb68fea71f..000000000000
--- a/www/linux-opera-devel/Makefile
+++ /dev/null
@@ -1,97 +0,0 @@
-# New ports collection makefile for: linux-opera
-# Date created: December 6th 2000
-# Whom: des
-#
-# $FreeBSD$
-#
-
-PORTNAME= opera
-PORTVERSION= 7.23.20031119
-CATEGORIES= www linux
-MASTER_SITES= ftp://ftp.sunet.se/pub/www/clients/Opera/linux/723/final/en/i386/static/ \
- ftp://sunsite.cnlab-switch.ch/mirror/opera/linux/723/final/en/i386/static/ \
- ftp://ftp.tiscali.nl/pub/mirrors/opera/linux/723/final/en/i386/static/ \
- ftp://ftp.ntua.gr/pub/www/Opera/linux/723/final/en/i386/static/ \
- http://mirrors.pmmf.hu/mirror/opera/linux/723/final/en/i386/static/ \
- ftp://ftp.task.gda.pl/pub/opera/linux/723/final/en/i386/static/ \
- ftp://ftp.planetmirror.com/pub/opera/linux/723/final/en/i386/static/ \
- http://gd.tuwien.ac.at/infosys/browsers/opera/linux/723/final/en/i386/static/ \
- ftp://ftp.opera.com/pub/opera/linux/723/final/en/i386/static/
-PKGNAMEPREFIX= linux-
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.2003/-2003/}.1-static-qt.i386-en
-
-MAINTAINER= mezz7@cox.net
-COMMENT= A blazingly fast, full-featured, standards-compliant browser
-
-CONFLICTS= opera-*
-RESTRICTED= "not redistributable; commercial software"
-
-.if defined(WITH_XFT2)
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libXrandr.so.2:${PORTSDIR}/x11/linux-XFree86-libs \
- ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
- ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat
-.else
-USE_LINUX= yes
-.endif
-
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libXm.so.2:${PORTSDIR}/x11-toolkits/linux-openmotif
-
-USE_BZIP2= yes
-USE_X_PREFIX= yes
-USE_REINPLACE= yes
-ONLY_FOR_ARCHS= i386
-
-NO_BUILD= yes
-NO_FILTER_SHLIBS=yes
-
-.include <bsd.port.pre.mk>
-
-.if exists(/etc/X11/applnk)
-PLIST_SUB+= APPLNK:=""
-.else
-PLIST_SUB+= APPLNK:="@comment "
-.endif
-
-.if exists(${X11BASE}/share/gnome)
-PLIST_SUB+= GNOME:=""
-.else
-PLIST_SUB+= GNOME:="@comment "
-.endif
-
-.if exists(${LOCALBASE}/share/applnk/Internet)
-PLIST_SUB+= KDE:=""
-.else
-PLIST_SUB+= KDE:="@comment "
-.endif
-
-.if exists(${LOCALBASE}/share/applnk/Networking)
-PLIST_SUB+= KDE2:=""
-.else
-PLIST_SUB+= KDE2:="@comment "
-.endif
-
-.if exists(${X11BASE}/share/gnome/apps)
-PLIST_SUB+= GNOMELNK:=""
-.else
-PLIST_SUB+= GNOMELNK:="@comment "
-.endif
-
-pre-everything::
-.if !defined(WITH_XFT2)
- @${ECHO_MSG} "You may specify the following on the command line:"
- @${ECHO_MSG} " "
- @${ECHO_MSG} "WITH_XFT2=yes for use Xft2 (requires linux_base-8) with nicer anti-aliased fonts."
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
- s|%%LOCALBASE%%|${LOCALBASE}|g ; s|%%X11BASE%%|${X11BASE}|g' \
- ${WRKSRC}/install.sh
-
-do-install:
- (cd ${WRKSRC} && ./install.sh --prefix=${PREFIX})
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>