aboutsummaryrefslogtreecommitdiff
path: root/www/linux-seamonkey/Makefile.common
diff options
context:
space:
mode:
Diffstat (limited to 'www/linux-seamonkey/Makefile.common')
-rw-r--r--www/linux-seamonkey/Makefile.common6
1 files changed, 6 insertions, 0 deletions
diff --git a/www/linux-seamonkey/Makefile.common b/www/linux-seamonkey/Makefile.common
index e0f7e57d203e..7f08cf1c9a43 100644
--- a/www/linux-seamonkey/Makefile.common
+++ b/www/linux-seamonkey/Makefile.common
@@ -39,15 +39,20 @@ DESKTOP_SUFFIX?= (Linux)
_A= >> ${TMPPLIST}
_Q= 2>/dev/null || true
+.if !target(post-extract)
post-extract:
@${RM} -rf ${WRKSRC}/updates
+.endif
.if ${CATEGORIES:Mwww}
+.if !target(post-patch)
post-patch:
@${ECHO} 'pref("general.useragent.vendor", "'${OPSYS}'");' >> ${PREFS_FILE}
@${ECHO} 'pref("general.useragent.vendorSub", "'${ARCH}'");' >> ${PREFS_FILE}
.endif
+.endif
+.if !target(do-install)
do-install:
@${INSTALL} -d ${FDIR} ${PREFIX}/share/applications
@${INSTALL_DATA} ${WRKDIR}/${APP_NAME}.desktop ${PREFIX}/share/applications/
@@ -60,6 +65,7 @@ do-install:
${FDIR}/plugins/ ${_Q}
@${CP} -R ${LOCALBASE}/lib/xpi/symlinks/${APP_NAME}/ \
${FDIR}/extensions/ ${_Q}
+.endif
# Maintainer section
create-plist: build