aboutsummaryrefslogtreecommitdiff
path: root/www/mmosaic/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mmosaic/Makefile')
-rw-r--r--www/mmosaic/Makefile57
1 files changed, 0 insertions, 57 deletions
diff --git a/www/mmosaic/Makefile b/www/mmosaic/Makefile
deleted file mode 100644
index ffb095f8db50..000000000000
--- a/www/mmosaic/Makefile
+++ /dev/null
@@ -1,57 +0,0 @@
-# New ports collection makefile for: mmosaic
-# Date created: 2000-12-26
-# Whom: trevor
-#
-# $FreeBSD$
-#
-
-PORTNAME= mmosaic
-PORTVERSION= 3.7.2
-PORTREVISION?= 7
-CATEGORIES= www
-MASTER_SITES= ftp://ftp.enst.fr/pub/mbone/mMosaic/ \
- ftp://ftp.uni-koeln.de/net/inet/WWW/mosaic/unix/ \
- ftp://ftp.netsw.org/infosys/www/clientside/browser/mosaic/
-DISTNAME= mMosaic-${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Web browser based on Mosaic, but with many modernizations
-
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2011-09-01
-BROKEN= fails to fetch
-
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png
-
-RESTRICTED= "academic, research and internal business purposes only, without a fee"
-PLIST= ${WRKDIR}/pkg-plist
-USE_MOTIF= yes
-USE_XORG= xmu xt xext x11
-WRKSRC= ${WRKDIR}/mMosaic-src-${PORTVERSION}
-
-post-patch:
-.for ii in libhtmlw/HTML-PSformat.c libhtmlw/HTML.c libhtmlw/HTMLcolors.c \
- libmc/mc_obj.c libnut/list.c src/proxy-dialogs.c
- ${MV} ${WRKSRC}/${ii} ${WRKSRC}/${ii}.orig
- ${GREP} -v malloc.h ${WRKSRC}/${ii}.orig > ${WRKSRC}/${ii}
-.endfor
-
-pre-install:
- ${ECHO_CMD} bin/mmosaic > ${PLIST}
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC}/Copyrights; for i in `${FIND} * -type f`; do \
- ${ECHO_CMD} %%DOCSDIR%%/$${i} >> ${PLIST}; \
- done
- ${ECHO_CMD} @dirrm %%DOCSDIR%% >> ${PLIST}
-.endif
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/mMosaic ${PREFIX}/bin/mmosaic
-# ${INSTALL_DATA} ${WRKSRC}/app-def/app-defaults.color ${PREFIX}/lib/X11/app-defaults/mMosaic
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Copyrights/* ${DOCSDIR}/
-.endif
-
-.include <bsd.port.mk>