aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_kerb2
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_auth_kerb2')
-rw-r--r--www/mod_auth_kerb2/Makefile58
-rw-r--r--www/mod_auth_kerb2/distinfo3
-rw-r--r--www/mod_auth_kerb2/files/patch-src__mod_auth_kerb.c25
-rw-r--r--www/mod_auth_kerb2/pkg-descr13
-rw-r--r--www/mod_auth_kerb2/pkg-plist3
5 files changed, 0 insertions, 102 deletions
diff --git a/www/mod_auth_kerb2/Makefile b/www/mod_auth_kerb2/Makefile
deleted file mode 100644
index 4c03da6334dd..000000000000
--- a/www/mod_auth_kerb2/Makefile
+++ /dev/null
@@ -1,58 +0,0 @@
-# New ports collection makefile for: mod_auth_kerb
-# Date created: 19 October 2001
-# Whom: wollman
-#
-# $FreeBSD$
-#
-
-# Shamelessly stolen from will's mod_auth_any port.
-
-PORTNAME= mod_auth_kerb
-PORTVERSION= 5.0.r6
-PORTREVISION= 1
-CATEGORIES= www
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR=modauthkerb
-DISTNAME= mod_auth_kerb-5.0-rc6
-
-MAINTAINER= apache@FreeBSD.org
-COMMENT= An Apache module for authenticating users with Kerberos v5
-
-#
-# This module allows users to send their Kerberos password in
-# plain text; it should only be used over an encrypted connection
-# (i.e., HTTP over SSL/TLS). Thus, we require as a dependency
-# a version of Apache which can do this.
-#
-USE_APACHE= 13
-# Don't fsck with CFLAGS
-CFLAGS:=
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-krb5=${KRB5_HOME} --without-krb4
-OPTIONS+= BASE_KERBEROS5 "Use the base Kerberos 5 (Heimdal)"
-.if exists(/usr/lib/libkrb5.so)
-OPTIONS+= on
-.else
-OPTIONS+= off
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700014
-BROKEN= "Does not compile on FreeBSD >= 7.0"
-.endif
-
-.if exists(${PREFIX}/sbin/apxs)
-APACHE_MODULE_DIR!=${PREFIX}/sbin/apxs -q LIBEXECDIR
-.else
-APACHE_MODULE_DIR=libexec/apache
-.endif
-PLIST_SUB+= APMODDIR=${APACHE_MODULE_DIR:S/^${PREFIX}\///}
-.if defined(WITH_BASE_KERBEROS5)
-KRB5_HOME= /usr
-.else
-LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
-KRB5_HOME= ${LOCALBASE}
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/www/mod_auth_kerb2/distinfo b/www/mod_auth_kerb2/distinfo
deleted file mode 100644
index 4830cf881d62..000000000000
--- a/www/mod_auth_kerb2/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (mod_auth_kerb-5.0-rc6.tar.gz) = 274edfb950af20ce6ef0ddcb7c20263a
-SHA256 (mod_auth_kerb-5.0-rc6.tar.gz) = ae33ab3ae5b419819725091d154add1a1d1a5d6d97e31e9f327f71a0b6370d3e
-SIZE (mod_auth_kerb-5.0-rc6.tar.gz) = 68761
diff --git a/www/mod_auth_kerb2/files/patch-src__mod_auth_kerb.c b/www/mod_auth_kerb2/files/patch-src__mod_auth_kerb.c
deleted file mode 100644
index 7c25d1a1004f..000000000000
--- a/www/mod_auth_kerb2/files/patch-src__mod_auth_kerb.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- src/mod_auth_kerb.c.orig Tue Aug 10 08:01:01 2004
-+++ src/mod_auth_kerb.c Wed Oct 5 20:25:38 2005
-@@ -1108,6 +1108,7 @@
- spnego_oid.elements = (void *)"\x2b\x06\x01\x05\x05\x02";
-
- if (conf->krb_5_keytab) {
-+#ifndef HEIMDAL
- char *ktname;
- /* we don't use the ap_* calls here, since the string passed to putenv()
- * will become part of the enviroment and shouldn't be free()ed by apache
-@@ -1120,6 +1121,14 @@
- }
- sprintf(ktname, "KRB5_KTNAME=%s", conf->krb_5_keytab);
- putenv(ktname);
-+#else
-+ ret = gsskrb5_register_acceptor_identity(conf->krb_5_keytab);
-+ if (ret) {
-+ log_rerror(APLOG_MARK, APLOG_ERR, 0, r, "Setting KerberosV keytab failed: %s", strerror(errno));
-+ ret = HTTP_INTERNAL_SERVER_ERROR;
-+ goto end;
-+ }
-+#endif
- }
-
- ret = get_gss_creds(r, conf, &server_creds);
diff --git a/www/mod_auth_kerb2/pkg-descr b/www/mod_auth_kerb2/pkg-descr
deleted file mode 100644
index 18a501ba29f6..000000000000
--- a/www/mod_auth_kerb2/pkg-descr
+++ /dev/null
@@ -1,13 +0,0 @@
-mod_auth_kerb is an Apache module for authenticating Web clients in a
-Kerberos v5 realm. Authentication may be performed via the Kerberos
-principal/password; it may also be done securely using SPNEGO (HTTP
-Negotiate auth protocol) to perform a GSSAPI/Kerberos authentication
-from the user's browser and Kerberos credentials directly to the server
-Kerberos credentials 'HTTP/host@REALM'. Because the Kerberos password is
-transmitted in plain text in the former mode, when using mod_auth_kerb
-for naive HTTP Basic (password-based) authentication, this module
-MUST be used in conjunction with an encryption-capable Web server
-(e.g. Apache) to keep that exchange private. There is no documentation
-provided; see the Web site for more details.
-
-WWW: http://modauthkerb.sourceforge.net/
diff --git a/www/mod_auth_kerb2/pkg-plist b/www/mod_auth_kerb2/pkg-plist
deleted file mode 100644
index e10a6259ef13..000000000000
--- a/www/mod_auth_kerb2/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-%%APMODDIR%%/mod_auth_kerb.so
-@exec %D/sbin/apxs -e -A -n auth_kerb %D/%F
-@unexec %D/sbin/apxs -e -A -n auth_kerb %D/%F