aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_mysql2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_auth_mysql2/Makefile')
-rw-r--r--www/mod_auth_mysql2/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/www/mod_auth_mysql2/Makefile b/www/mod_auth_mysql2/Makefile
index 8b15023a4596..abae59b1a3ce 100644
--- a/www/mod_auth_mysql2/Makefile
+++ b/www/mod_auth_mysql2/Makefile
@@ -6,34 +6,35 @@
#
PORTNAME= mod_auth_mysql
-PORTVERSION= 1.7
+PORTVERSION= 1.9.1
CATEGORIES= www
-MASTER_SITES= http://www.heuer.org/mod_auth_mysql/
+MASTER_SITES= http://www.heuer.org/mod_auth_mysql/ \
+ http://www.heuer.org/mod_auth_mysql/old/
DISTNAME= ${PORTNAME}_${PORTVERSION}
EXTRACT_SUFX= .tgz
-DIST_SUBDIR= apache20
+DIST_SUBDIR= apache22
MAINTAINER= apache@FreeBSD.org
COMMENT= MySQL-based authentication module with VirtualHost support
-BROKEN= Unfetchable
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2007-04-10
-
LATEST_LINK= mod_auth_mysql2
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_MYSQL= YES
-USE_APACHE= 20
+USE_APACHE= 2.0+
AP_FAST_BUILD= YES
AP_GENPLIST= YES
AP_INC+= ${LOCALBASE}/include/mysql
AP_LIB+= ${LOCALBASE}/lib/mysql -lmysqlclient
+.if !defined(NOPORTDOCS)
PORTDOCS= INSTALL example_data.html htpasswd.sql
+.endif
post-install:
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
.include <bsd.port.mk>