aboutsummaryrefslogtreecommitdiff
path: root/www/mod_clamav/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_clamav/Makefile')
-rw-r--r--www/mod_clamav/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/www/mod_clamav/Makefile b/www/mod_clamav/Makefile
new file mode 100644
index 000000000000..f27210441a91
--- /dev/null
+++ b/www/mod_clamav/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mod_clamav
+# Date created: Sun Oct 19
+# Whom: Clement Laforet <clement@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_clamav
+PORTVERSION= 0.19
+CATEGORIES= www security
+MASTER_SITES= http://software.othello.ch/mod_clamav/
+
+MAINTAINER= tmueko@kommunity.net
+COMMENT= Scans content delivered by the Apache2 proxy module for viruses
+
+LIB_DEPENDS+= clamav:${PORTSDIR}/${CLAMAV_PORT}
+
+USE_APACHE= YES
+WITH_APACHE2= YES
+USE_LIBTOOL= YES
+
+.if defined(WITH_CLAMAVDEVEL)
+CLAMAV_PORT= security/clamav-devel
+.else
+CLAMAV_PORT= security/clamav
+.endif
+
+CONFIGURE_ARGS= --with-apxs=${PREFIX}/sbin/apxs \
+ --libdir=${PREFIX}/lib/apache2
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>