aboutsummaryrefslogtreecommitdiff
path: root/www/mod_cvs
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_cvs')
-rw-r--r--www/mod_cvs/Makefile30
-rw-r--r--www/mod_cvs/distinfo1
-rw-r--r--www/mod_cvs/pkg-comment1
-rw-r--r--www/mod_cvs/pkg-descr13
-rw-r--r--www/mod_cvs/pkg-message6
-rw-r--r--www/mod_cvs/pkg-plist3
6 files changed, 54 insertions, 0 deletions
diff --git a/www/mod_cvs/Makefile b/www/mod_cvs/Makefile
new file mode 100644
index 000000000000..d10a5e819180
--- /dev/null
+++ b/www/mod_cvs/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: mod_cvs
+# Date created: 14 August 2001
+# Whom: petef
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_cvs
+PORTVERSION= 0.5
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.sub.nu/pub/mod_cvs/ \
+ ftp://ftp.isk.kth.se/pub/people/main/mod_cvs/
+
+MAINTAINER= petef@FreeBSD.org
+
+BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+
+MAKE_ARGS+= APXS="${APXS}"
+
+APXS?= ${LOCALBASE}/sbin/apxs
+
+post-patch:
+ @${PERL} -pi -e 's,apxs,${APXS},g' ${WRKSRC}/Makefile
+
+do-install:
+ ${APXS} -i -A -n cvs ${WRKSRC}/mod_cvs.so
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/mod_cvs/distinfo b/www/mod_cvs/distinfo
new file mode 100644
index 000000000000..c0c15b4aad01
--- /dev/null
+++ b/www/mod_cvs/distinfo
@@ -0,0 +1 @@
+MD5 (mod_cvs-0.5.tar.gz) = e2cfe7818337915e6cbaffa45852012f
diff --git a/www/mod_cvs/pkg-comment b/www/mod_cvs/pkg-comment
new file mode 100644
index 000000000000..02a4e99afe5d
--- /dev/null
+++ b/www/mod_cvs/pkg-comment
@@ -0,0 +1 @@
+A module that makes Apache CVS aware
diff --git a/www/mod_cvs/pkg-descr b/www/mod_cvs/pkg-descr
new file mode 100644
index 000000000000..5cf238b82c17
--- /dev/null
+++ b/www/mod_cvs/pkg-descr
@@ -0,0 +1,13 @@
+mod_cvs recognizes if the files in your webtree are checked out
+from a CVS repository. If so, it checks if the file is up-to-date
+and, if not, updates it.
+
+Another neat feature of mod_cvs is the date-checkout feature. You
+can specify a date in the URI that gets passed to CVS, which checks
+out an older revision of the requested file and sends it to the
+user.
+
+WWW: http://www.sub.nu/mod_cvs/
+
+- Pete
+petef@FreeBSD.org
diff --git a/www/mod_cvs/pkg-message b/www/mod_cvs/pkg-message
new file mode 100644
index 000000000000..980fb7be273b
--- /dev/null
+++ b/www/mod_cvs/pkg-message
@@ -0,0 +1,6 @@
+-----------------------------------------------------------------
+You have installed mod_cvs, a module that makes Apache CVS aware.
+
+For help on using this module, please see the mod_cvs reference:
+ http://www.sub.nu/mod_cvs/reference.shtml
+-----------------------------------------------------------------
diff --git a/www/mod_cvs/pkg-plist b/www/mod_cvs/pkg-plist
new file mode 100644
index 000000000000..96f82cea4022
--- /dev/null
+++ b/www/mod_cvs/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache/mod_cvs.so
+@exec %D/sbin/apxs -e -a -n cvs %D/%f
+@unexec echo "===> If you do not plan on reinstalling mod_cvs, you must manually remove"; echo "===> references to it in httpd.conf."