aboutsummaryrefslogtreecommitdiff
path: root/www/mod_dtcl/files/Makefile.bsd
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_dtcl/files/Makefile.bsd')
-rw-r--r--www/mod_dtcl/files/Makefile.bsd7
1 files changed, 4 insertions, 3 deletions
diff --git a/www/mod_dtcl/files/Makefile.bsd b/www/mod_dtcl/files/Makefile.bsd
index eec33906d5a3..7017ba283ab9 100644
--- a/www/mod_dtcl/files/Makefile.bsd
+++ b/www/mod_dtcl/files/Makefile.bsd
@@ -9,9 +9,7 @@ DTCL_VERSION!= cat ${.CURDIR}/VERSION
CC!= ${PREFIX}/sbin/apxs -q CC
CFLAGS!= ${PREFIX}/sbin/apxs -q CFLAGS CFLAGS_SHLIB
-CFLAGS+= -Wall -DSTATUS -DNO_DBM_REWRITEMAP ${INCLUDES}
-CFLAGS+= -DDEBUG_SCRIPT_DIR="\"${PREFIX}/share/mod_dtcl/\""
-CFLAGS+= -DDTCL_VERSION="\"${DTCL_VERSION}\""
+CFLAGS+= ${INCLUDES} -DDTCL_VERSION="\"${DTCL_VERSION}\""
LIB= mod_dtcl
SHLIB_MAJOR=1
@@ -24,6 +22,9 @@ NOPROFILE= True # to avoid building profiled library
INTERNALLIB= True # to avoid building a static version
SRCS= mod_dtcl.c
+SRCS+= apache_cookie.c apache_multipart_buffer.c apache_request.c \
+ tcl_commands.c
+
NOMAN= True # don't bother with the man-page here, let the port handle it
all: ${SHLIB_NAME}