aboutsummaryrefslogtreecommitdiff
path: root/www/mod_fastcgi
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_fastcgi')
-rw-r--r--www/mod_fastcgi/Makefile62
-rw-r--r--www/mod_fastcgi/pkg-plist4
2 files changed, 9 insertions, 57 deletions
diff --git a/www/mod_fastcgi/Makefile b/www/mod_fastcgi/Makefile
index f0814aa5b835..9dbe870aa2ab 100644
--- a/www/mod_fastcgi/Makefile
+++ b/www/mod_fastcgi/Makefile
@@ -14,63 +14,19 @@ MASTER_SITES= ftp://ftp.holywar.net/pub/FreeBSD/ \
MAINTAINER= hollywar@mail.holywar.net
COMMENT= A fast-cgi module for Apache
-BUILD_DEPENDS= ${APXS}:${PORTSDIR}/${APACHE_PORT}
-
CONFLICTS= apache-contrib-1.*
-APACHE_COMPAT= YES
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_APACHE2) || exists(${LOCALBASE}/include/apache2/apr.h)
-WITH_APACHE2= YES
-MAKEFILE= Makefile.AP2
-USE_REINPLACE= YES
-MAKE_ARGS= INCLUDES=-I${PREFIX}/include/apache2
-INSTALL_TARGET= install-modules
-PLIST_SUB= APACHE=2
-.else
-PLIST_SUB= APACHE=
-.endif
-
-.if defined(WITHOUT_APACHE_SUEXEC)
-APXSOPTS+= -DNO_SUEXEC_FOR_AP_USER_N_GROUP
-.endif
-
-do-patch:
-.if defined(WITH_APACHE2)
- @${REINPLACE_CMD} -e "s|/usr/local/apache2|${PREFIX}/share/apache2|g" ${WRKSRC}/${MAKEFILE}
-.else
- cd ${WRKSRC} ; ${MV} Makefile.tmpl Makefile ;
-
-do-build:
- cd ${WRKSRC} ; ${LOCALBASE}/sbin/apxs -o mod_fastcgi.so -c ${APXSOPT} *.c
-
-do-install:
- cd ${WRKSRC} ; ${LOCALBASE}/sbin/apxs -i -a -n fastcgi mod_fastcgi.so
-.endif
+USE_APACHE= 1.3+
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+SRC_FILE= *.c
+PORTDOCS= LICENSE.TERMS mod_fastcgi.html
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in LICENSE.TERMS mod_fastcgi.html
- ${INSTALL_DATA} ${WRKSRC}/docs/${file} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/docs/${f} ${DOCSDIR}
.endfor
.endif
- @${ECHO_MSG} "************************************************************"
-.if !defined(WITH_APACHE2)
- @${ECHO_MSG} "* Fast-cgi modules was included with your apache *"
- @${ECHO_MSG} "* configuration file *"
- @${ECHO_MSG} "* *"
-.endif
- @${ECHO_MSG} "* You need to add following lines to your apache *"
- @${ECHO_MSG} "* configuration file. and restart it ! *"
- @${ECHO_MSG} "* *"
-.if defined(WITH_APACHE2)
- @${ECHO_MSG} "* LoadModule fastcgi_module libexec/apache2/mod_fastcgi.so *"
-.endif
- @${ECHO_MSG} "* AddHandler fastcgi-script fcgi fcgi fpl *"
- @${ECHO_MSG} "* *"
- @${ECHO_MSG} "************************************************************"
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/mod_fastcgi/pkg-plist b/www/mod_fastcgi/pkg-plist
deleted file mode 100644
index 69ff1d27dd63..000000000000
--- a/www/mod_fastcgi/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-libexec/apache%%APACHE%%/mod_fastcgi.so
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE.TERMS
-%%PORTDOCS%%%%DOCSDIR%%/mod_fastcgi.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%