aboutsummaryrefslogtreecommitdiff
path: root/www/mod_line_edit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_line_edit/Makefile')
-rw-r--r--www/mod_line_edit/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/www/mod_line_edit/Makefile b/www/mod_line_edit/Makefile
new file mode 100644
index 000000000000..24e3ebd87fcc
--- /dev/null
+++ b/www/mod_line_edit/Makefile
@@ -0,0 +1,36 @@
+# New ports collection Makefile for: mod_line_edit
+#
+# Date created: 10/01/2007
+# Whom: Dominic Marks <dom@goodforbusiness.co.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_line_edit
+PORTVERSION= 1.0.0
+CATEGORIES= www
+MASTER_SITES= http://apache.webthing.com/mod_line_edit/
+DISTFILES= mod_line_edit.c
+
+MAINTAINER= dom@helenmarks.co.uk
+COMMENT= Apache module for simple text rewriting
+
+USE_APACHE= yes
+WITH_APACHE2= yes
+
+do-extract:
+ @${DO_NADA}
+
+pre-fetch:
+ @${MKDIR} ${WRKDIR}
+
+post-fetch:
+ @${CP} ${DISTDIR}/mod_line_edit.c ${WRKDIR}
+
+do-build:
+ @(cd ${WRKDIR} && ${APXS} -c mod_line_edit.c)
+
+do-install:
+ @(cd ${WRKDIR} && ${APXS} -A -i mod_line_edit.la)
+
+.include <bsd.port.mk>