aboutsummaryrefslogtreecommitdiff
path: root/www/mod_perl2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_perl2/Makefile')
-rw-r--r--www/mod_perl2/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
index 12a04014bbd1..cf5108ad19c4 100644
--- a/www/mod_perl2/Makefile
+++ b/www/mod_perl2/Makefile
@@ -65,10 +65,13 @@ MAN3= APR.3 APR::Base64.3 APR::Brigade.3 APR::Bucket.3 \
.include <bsd.port.pre.mk>
+.if ${APACHE_VERSION} > 22
+BROKEN= Does not build with apache24
+.endif
+
# Using apxs in this way is problematic if apache2 is installed under a
# different PREFIX than mod_perl2, because the mod_perl2 installation will
# use paths returned by apxs to install some components. Fixes welcome.
-#CONFIGURE_ARGS= MP_APXS=${LOCALBASE}/sbin/apxs PREFIX=${PREFIX}
CONFIGURE_ARGS= PREFIX=${PREFIX} MP_APXS=${APXS} MP_APR_CONFIG=${LOCALBASE}/bin/apr-1-config
.if exists(${LOCALBASE}/include/apr-1/apr.h)