aboutsummaryrefslogtreecommitdiff
path: root/www/mod_perl2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_perl2/Makefile')
-rw-r--r--www/mod_perl2/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
index cf5108ad19c4..8ef61f37fbb5 100644
--- a/www/mod_perl2/Makefile
+++ b/www/mod_perl2/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: mod_perl2
-# Date created: February 13th 2003
-# Whom: Lars Eggert <larse@isi.edu>
-#
+# Created by: Lars Eggert <larse@isi.edu>
# $FreeBSD$
-#
PORTNAME= mod_perl
-PORTVERSION= 2.0.7
-PORTREVISION= 1
+PORTVERSION= 2.0.8
PORTEPOCH= 3
CATEGORIES= www perl5
MASTER_SITES= APACHE/perl
@@ -96,6 +91,9 @@ PLIST_SUB+= THREADRWLOCK="@comment "
post-patch:
${REINPLACE_CMD} -e 's/APR_INLINE//g' \
${PATCH_WRKSRC}/src/modules/perl/modperl_common_util.h
+ ${REINPLACE_CMD} -e "s|/usr/local/apache/bin/apxs|${APXS}|" \
+ -e "s|'bin', 'apxs'|'sbin', 'apxs'|" \
+ ${WRKSRC}/lib/Apache2/Build.pm
post-configure:
${REINPLACE_CMD} -e 's/-pthread -Wl,-E//g' \
@@ -114,4 +112,7 @@ post-install:
${APXS} -e -A -n perl ${PREFIX}/${APACHEMODDIR}/mod_perl.so
@${CAT} ${PKGMESSAGE}
+test: build
+ -@(cd ${WRKSRC} && ${MAKE} test)
+
.include <bsd.port.post.mk>