aboutsummaryrefslogtreecommitdiff
path: root/www/mod_python3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_python3/Makefile')
-rw-r--r--www/mod_python3/Makefile19
1 files changed, 2 insertions, 17 deletions
diff --git a/www/mod_python3/Makefile b/www/mod_python3/Makefile
index f1df60aa412d..afdec29ccf39 100644
--- a/www/mod_python3/Makefile
+++ b/www/mod_python3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mod_python
PORTVERSION= 3.1.4
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR= modpython
@@ -17,7 +18,7 @@ COMMENT= Apache module that embeds the Python interpreter within the server
WITH_APACHE2= yes
USE_APACHE= yes
-USE_PYTHON= yes
+USE_PYTHON= 2.3+
LATEST_LINK= mod_python3
GNU_CONFIGURE= yes
@@ -27,26 +28,10 @@ MAKE_ENV= EXPR_COMPAT=yes
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64" || ${ARCH} == "amd64"
-BROKEN= "Does not compile on amd64 or ia64"
-.endif
-
-.if ${PYTHON_REL} >= 230
post-patch:
${REINPLACE_CMD} -e 's,LONG_LONG,long long,g' ${WRKSRC}/src/requestobject.c
-.endif
-
-.if !exists(${PREFIX}/etc/apache2/envvars.d) && !defined(PACKAGE_BUILDING)
-BROKEN= "Please upgrade your www/apache2 installation."
-.endif
-
-post-build:
- THREAD_LIB=`ldd ${PYTHON_CMD} | ${EGREP} '(pthread|c_r)' | ${AWK} '{print $$3}'`; \
- ${ECHO_CMD} "LD_PRELOAD=$${THREAD_LIB}" > ${WRKDIR}/mod_python3.env
- ${ECHO_CMD} "export LD_PRELOAD" >> ${WRKDIR}/mod_python3.env
post-install:
- ${INSTALL_DATA} ${WRKDIR}/mod_python3.env ${PREFIX}/etc/apache2/envvars.d
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>