aboutsummaryrefslogtreecommitdiff
path: root/www/mod_ruby/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_ruby/Makefile')
-rw-r--r--www/mod_ruby/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/www/mod_ruby/Makefile b/www/mod_ruby/Makefile
index a4bd60985760..d012ce3b4efe 100644
--- a/www/mod_ruby/Makefile
+++ b/www/mod_ruby/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mod_ruby
-PORTVERSION= 0.9.7
+PORTVERSION= 0.9.8
CATEGORIES= www ruby
MASTER_SITES= http://www.modruby.net/archive/
DIST_SUBDIR= ruby
@@ -18,6 +18,9 @@ LIB_DEPENDS= eruby.09:${PORTSDIR}/textproc/eruby
RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
USE_RUBY= yes
+.if !defined(NOPORTDOCS)
+USE_RUBY_RD= yes
+.endif
APXS= ${LOCALBASE}/sbin/apxs
@@ -27,12 +30,17 @@ CONFIGURE_ARGS= --with-apxs="${APXS}" \
--with-eruby-libraries="${LOCALBASE}/lib"
INSTALL_TARGET= site-install
-DOCS_EN= COPYING ChangeLog README.en
-DOCS_JA= README.ja
+DOCS_EN= COPYING ChangeLog README.en doc/default.css doc/*.en.*
+DOCS_JA= README.ja doc/default.css doc/*.ja.*
do-configure:
@cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${RUBY} ${RUBY_FLAGS} configure.rb ${CONFIGURE_ARGS}
+post-build:
+.if !defined(NOPORTDOCS)
+ @cd ${WRKSRC}/doc; ${MAKE}
+.endif
+
post-install:
${INSTALL_DATA} ${WRKSRC}/examples/httpd.conf ${PREFIX}/etc/apache/httpd.conf.${PORTNAME}
.if !defined(NOPORTDOCS)