aboutsummaryrefslogtreecommitdiff
path: root/www/mod_scgi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_scgi/Makefile')
-rw-r--r--www/mod_scgi/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/www/mod_scgi/Makefile b/www/mod_scgi/Makefile
index 445a4ae864cd..997811728cac 100644
--- a/www/mod_scgi/Makefile
+++ b/www/mod_scgi/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= scgi
-PORTVERSION= 1.10
+PORTVERSION= 1.11
CATEGORIES= www
-MASTER_SITES= http://www.mems-exchange.org/software/files/scgi/ \
+MASTER_SITES= http://quixote.python.ca/releases/ \
http://dryice.name/computer/FreeBSD/distfiles/
PKGNAMEPREFIX= mod_
DISTNAME= scgi-${PORTVERSION:S/.a/a/}
@@ -16,21 +16,17 @@ DISTNAME= scgi-${PORTVERSION:S/.a/a/}
MAINTAINER= dryice@dryice.name
COMMENT= Apache module that implements the client side of the SCGI protocol
-USE_APACHE= yes
+USE_APACHE= 1.3+
WRKSRC= ${WRKDIR}/${DISTNAME}/${SCGI_DIR}
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/include/apache2/apr.h)
-WITH_APACHE2= yes
-.endif
-.if defined(WITH_APACHE2)
+.if ${APACHE_VERSION} >= 20
SCGI_DIR= apache2
-PLIST_SUB= APACHE_DIR=apache2
.else
SCGI_DIR= apache1
-PLIST_SUB= APACHE_DIR=apache
.endif
+PLIST_SUB= APACHE_DIR=${APACHEMODDIR}
do-build:
cd ${WRKSRC} && ${APXS} -c mod_scgi.c