aboutsummaryrefslogtreecommitdiff
path: root/www/mod_security/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_security/Makefile')
-rw-r--r--www/mod_security/Makefile40
1 files changed, 16 insertions, 24 deletions
diff --git a/www/mod_security/Makefile b/www/mod_security/Makefile
index 632f232648f7..5f416b96e369 100644
--- a/www/mod_security/Makefile
+++ b/www/mod_security/Makefile
@@ -1,15 +1,9 @@
-# New ports collection makefile for: mod_security
-# Date created: 4 June 2003
-# Whom: Marcelo Araujo <araujo@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= mod_security
-PORTVERSION= 2.6.6
-PORTREVISION= 1
+PORTVERSION= 2.7.3
CATEGORIES= www security
-MASTER_SITES= SF/mod-security/modsecurity-apache/${PORTVERSION}
+MASTER_SITES= http://www.modsecurity.org/tarball/${PORTVERSION}/
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME:S/_//:S/2//}-apache_${PORTVERSION}
@@ -19,7 +13,7 @@ COMMENT= An intrusion detection and prevention engine
LICENSE= AL2
MAKE_JOBS_SAFE= yes
-LIB_DEPENDS+= pcre.3:${PORTSDIR}/devel/pcre \
+LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre \
apr-1:${PORTSDIR}/devel/apr1
USE_APACHE= 22+
@@ -39,36 +33,34 @@ PLIST_FILES= etc/modsecurity.conf-example \
${APACHEMODDIR}/mod_security2.so \
bin/rules-updater.pl \
lib/mod_security2.so
-OPTIONS= LUA "Embedded Lua language support" off \
- MLOGC "Build ModSecurity Log Collector" off
+
+OPTIONS_DEFINE= LUA MLOGC
+MLOGC_DESC= Build ModSecurity Log Collector
.include <bsd.port.pre.mk>
-.if defined(WITH_MLOGC)
-PLIST_FILES+= bin/mlogc
+.if ${PORT_OPTIONS:MMLOGC}
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+= --with-curl=${LOCALBASE} --disable-errors
+PLIST_FILES+= bin/mlogc bin/mlogc-batch-load.pl
+.else
+CONFIGURE_ARGS+= --disable-mlogc
.endif
-.if defined(WITH_LUA)
+.if ${PORT_OPTIONS:MLUA}
USE_LUA= 5.1+
CONFIGURE_ARGS+= --with-lua=${LOCALBASE}
-LIB_DEPENDS+= lua-5.1.1:${PORTSDIR}/lang/lua
+LIB_DEPENDS+= lua-5.1.5:${PORTSDIR}/lang/lua
.else
CONFIGURE_ARGS+= --without-lua
.endif
-.if defined(WITH_MLOGC)
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
-CONFIGURE_ARGS+= --with-curl=${LOCALBASE} --disable-errors
-.else
-CONFIGURE_ARGS+= --disable-mlogc
-.endif
-
REINPLACE_ARGS= -i ""
AP_EXTRAS+= -DWITH_LIBXML2
CONFIGURE_ARGS+= --with-apxs=${APXS} --with-pcre=${LOCALBASE}
post-build:
-.if defined(WITH_MLOGC)
+.if ${PORT_OPTIONS:MMLOGC}
# XXX there is "mlogc-static" target in the Makefile, too
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} mlogc
.endif
@@ -79,7 +71,7 @@ post-install:
@${MKDIR} ${DOCSDIR}
@(cd ${WRKSRC} && ${COPYTREE_SHARE} "doc" ${DOCSDIR}/)
.endif
-.if defined(WITH_MLOGC)
+.if ${PORT_OPTIONS:MMLOGC}
${INSTALL_PROGRAM} ${WRKSRC}/mlogc/mlogc ${PREFIX}/bin/
.endif