aboutsummaryrefslogtreecommitdiff
path: root/www/mod_security
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_security')
-rw-r--r--www/mod_security/Makefile24
-rw-r--r--www/mod_security/distinfo4
2 files changed, 12 insertions, 16 deletions
diff --git a/www/mod_security/Makefile b/www/mod_security/Makefile
index 2fa2882d3df5..4fd840b2acfa 100644
--- a/www/mod_security/Makefile
+++ b/www/mod_security/Makefile
@@ -1,14 +1,13 @@
# $FreeBSD$
PORTNAME= mod_security
-PORTVERSION= 2.7.4
-PORTREVISION= 2
+PORTVERSION= 2.7.7
CATEGORIES= www security
MASTER_SITES= http://www.modsecurity.org/tarball/${PORTVERSION}/
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME:S/_//:S/2//}-apache_${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= walter@lifeforms.nl
COMMENT= Intrusion detection and prevention engine
LICENSE= APACHE20
@@ -17,18 +16,21 @@ LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre \
libapr-1.so:${PORTSDIR}/devel/apr1
USE_APACHE= 22+
+USE_GNOME= libxml2
GNU_CONFIGURE= yes
+
AP_GENPLIST= yes
AP_INC= ${LOCALBASE}/include/libxml2
AP_LIB= ${LOCALBASE}/lib
-USE_GNOME= libxml2
MODULENAME= mod_security2
SRC_FILE= *.c
+
PORTDOCS= *
-DOCS= CHANGES LICENSE README.TXT modsecurity.conf-minimal
DOCSDIR= ${PREFIX}/share/doc/${MODULENAME}
+
SUB_FILES+= mod_security2.conf
SUB_LIST+= APACHEETCDIR="${APACHEETCDIR}"
+
PLIST_FILES= etc/modsecurity.conf-example \
${APACHEMODDIR}/mod_security2.so \
bin/rules-updater.pl \
@@ -46,28 +48,22 @@ MLOGC_CONFIGURE_OFF= --disable-mlogc
MLOGC_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
MLOGC_PLIST_FILES= bin/mlogc bin/mlogc-batch-load.pl
+# ap2x- prefix OPTIONSFILE fix
+OPTIONSFILE= ${PORT_DBDIR}/www_mod_security/options
.include <bsd.port.options.mk>
REINPLACE_ARGS= -i ""
AP_EXTRAS+= -DWITH_LIBXML2
CONFIGURE_ARGS+= --with-apxs=${APXS} --with-pcre=${LOCALBASE}
-post-build:
-.if ${PORT_OPTIONS:MMLOGC}
- # XXX there is "mlogc-static" target in the Makefile, too
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} mlogc
-.endif
-
pre-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}
post-install:
${INSTALL_DATA} ${WRKSRC}/modsecurity.conf-recommended \
${STAGEDIR}${PREFIX}/etc/modsecurity.conf-example
+
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} "doc" ${STAGEDIR}${DOCSDIR})
-.if ${PORT_OPTIONS:MMLOGC}
- ${INSTALL_PROGRAM} ${WRKSRC}/mlogc/mlogc ${STAGEDIR}${PREFIX}/bin
-.endif
.include <bsd.port.mk>
diff --git a/www/mod_security/distinfo b/www/mod_security/distinfo
index 89567bb64c07..ae9b991bac4e 100644
--- a/www/mod_security/distinfo
+++ b/www/mod_security/distinfo
@@ -1,2 +1,2 @@
-SHA256 (modsecurity-apache_2.7.4.tar.gz) = 605d6f1b03e648001ef1c7db7b18d51c01edd443b57cbbd4e298770ffdcd0eb9
-SIZE (modsecurity-apache_2.7.4.tar.gz) = 1014983
+SHA256 (modsecurity-apache_2.7.7.tar.gz) = 11e05cfa6b363c2844c6412a40ff16f0021e302152b38870fd1f2f44b204379b
+SIZE (modsecurity-apache_2.7.7.tar.gz) = 1003835