aboutsummaryrefslogtreecommitdiff
path: root/www/netrik/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/netrik/Makefile')
-rw-r--r--www/netrik/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/www/netrik/Makefile b/www/netrik/Makefile
index c52a4fa22aa2..068019f3a494 100644
--- a/www/netrik/Makefile
+++ b/www/netrik/Makefile
@@ -8,26 +8,32 @@
#
PORTNAME= netrik
-PORTVERSION= 1.2.1
+PORTVERSION= 1.8.0
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sysadmin@alexdupre.com
COMMENT= A text web browser, very ambitious, in active development
+RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
+
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${CPPLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= netrik.1
MAN5= netrikrc.5
-.if !exists(/usr/include/getopt.h)
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib -lgnugetopt
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+.endif
+.if ${OSVERSION} < 400000
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>