aboutsummaryrefslogtreecommitdiff
path: root/www/netsurf
diff options
context:
space:
mode:
Diffstat (limited to 'www/netsurf')
-rw-r--r--www/netsurf/Makefile3
-rw-r--r--www/netsurf/files/patch-utils_idna.c11
2 files changed, 13 insertions, 1 deletions
diff --git a/www/netsurf/Makefile b/www/netsurf/Makefile
index b68819d4533d..958d10a2606a 100644
--- a/www/netsurf/Makefile
+++ b/www/netsurf/Makefile
@@ -3,6 +3,7 @@
PORTNAME= netsurf
PORTVERSION= 3.9
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://download.netsurf-browser.org/netsurf/releases/source/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -20,7 +21,7 @@ BUILD_DEPENDS= duk:lang/duktape \
LIB_DEPENDS= libcurl.so:ftp/curl \
libpng.so:graphics/png \
libnsutils.so:devel/libnsutils \
- libutf8proc.so:textproc/libutf8proc \
+ libutf8proc.so:textproc/utf8proc \
libnsgif.so:graphics/libnsgif \
libnsbmp.so:graphics/libnsbmp \
libdom.so:www/libdom \
diff --git a/www/netsurf/files/patch-utils_idna.c b/www/netsurf/files/patch-utils_idna.c
new file mode 100644
index 000000000000..4e628c279dd3
--- /dev/null
+++ b/www/netsurf/files/patch-utils_idna.c
@@ -0,0 +1,11 @@
+--- utils/idna.c.orig 2019-09-15 12:06:06.236299000 +0200
++++ utils/idna.c 2019-09-15 12:06:07.393935000 +0200
+@@ -27,7 +27,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <sys/types.h>
+-#include <libutf8proc/utf8proc.h>
++#include <utf8proc.h>
+
+ #include "netsurf/inttypes.h"
+