aboutsummaryrefslogtreecommitdiff
path: root/www/nginx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/nginx/Makefile')
-rw-r--r--www/nginx/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 46c5e4962fc7..4a5bd7f76932 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.1.33
+PORTVERSION= 0.1.35
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
@@ -36,6 +36,11 @@ CONFIGURE_ARGS+=--prefix=${PREFIX}/etc/nginx \
--with-http_stub_status_module \
--user=${WWWOWN} --group=${WWWGRP}
+.if defined(WITH_OPENSSL_MODULE)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+=--with-http_ssl_module
+.endif
+
.if defined(WITHOUT_HTTP_REWRITE_MODULE) || defined(WITHOUT_PCRE)
PKGNAMESUFFIX= -nopcre
CONFIGURE_ARGS+=--without-http_rewrite_module \