aboutsummaryrefslogtreecommitdiff
path: root/www/node/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/node/Makefile')
-rw-r--r--www/node/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index 0591fec0ff68..e3ffaa949043 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= node
-PORTVERSION= 12.4.0
+PORTVERSION= 12.8.1
DISTVERSIONPREFIX= v
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
@@ -66,8 +66,8 @@ MAKE_ENV+= CC.host=${CC} CFLAGS.host="${CFLAGS}" \
LINK.host=${CXX} LDFLAGS.host="${LDFLAGS}"
BUILD_DEPENDS+= c-ares>=1.15.0:dns/c-ares\
- libuv>=1.29.1:devel/libuv \
- libnghttp2>=1.38.0:www/libnghttp2
+ libuv>=1.30.1:devel/libuv \
+ libnghttp2>=1.39.2:www/libnghttp2
LIB_DEPENDS+= libcares.so:dns/c-ares\
libuv.so:devel/libuv \
libnghttp2.so:www/libnghttp2
@@ -78,7 +78,7 @@ LIB_DEPENDS+= libcares.so:dns/c-ares\
BROKEN_SSL+= base
.endif
-.if ${PORT_OPTIONS:MBUNDLED_SSL} && ${ARCH} != amd64 && ${ARCH} != i386
+.if ${PORT_OPTIONS:MBUNDLED_SSL} && ${ARCH} != amd64
CONFIGURE_ARGS+=--openssl-no-asm
.endif