aboutsummaryrefslogtreecommitdiff
path: root/www/node14/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/node14/Makefile')
-rw-r--r--www/node14/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/www/node14/Makefile b/www/node14/Makefile
index 9ca68ecd8cc9..5b3a629c2771 100644
--- a/www/node14/Makefile
+++ b/www/node14/Makefile
@@ -2,7 +2,7 @@
PORTNAME= node
DISTVERSIONPREFIX= v
-DISTVERSION= 14.15.5
+DISTVERSION= 14.16.0
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${DISTVERSION}/
PKGNAMESUFFIX= 14
@@ -17,6 +17,9 @@ BROKEN_SSL= libressl libressl-devel
BROKEN_SSL_REASON= Node.js 14.x LTS requires OpenSSL 1.1.x or the BUNDLED_SSL option enabled
ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386 powerpc64 powerpc64le
+USES= compiler:c++11-lib gmake python:build pkgconfig \
+ localbase shebangfix
+
OPTIONS_DEFINE= BUNDLED_SSL DOCS NLS DTRACE
OPTIONS_DEFAULT= DTRACE
OPTIONS_DEFAULT_FreeBSD_11= BUNDLED_SSL
@@ -45,9 +48,6 @@ NLS_LIB_DEPENDS= libicui18n.so:devel/icu
DTRACE_CONFIGURE_ON= --with-dtrace
-USES= compiler:c++11-lib gmake python:build pkgconfig \
- localbase shebangfix
-
HAS_CONFIGURE= yes
CONFLICTS_INSTALL= node10-[0-9]* node12-[0-9]* node-[0-9]*