aboutsummaryrefslogtreecommitdiff
path: root/www/npm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/npm/Makefile')
-rw-r--r--www/npm/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index 5d7311c6fc39..887a4a1a3107 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -3,6 +3,7 @@
PORTNAME= npm
PORTVERSION= 6.9.0
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= LOCAL/sunpoet
@@ -56,4 +57,9 @@ post-patch:
do-install:
cd ${WRKSRC}/ && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/
+post-install:
+ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
+ -d ${PREFIX}/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp -f \
+ ${STAGEDIR}${PREFIX}/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp
+
.include <bsd.port.post.mk>