aboutsummaryrefslogtreecommitdiff
path: root/www/opera-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/opera-devel/Makefile')
-rw-r--r--www/opera-devel/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/www/opera-devel/Makefile b/www/opera-devel/Makefile
index 7a2189607222..e0abdf804029 100644
--- a/www/opera-devel/Makefile
+++ b/www/opera-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= opera
PORTVERSION= ${OPERA_VER}
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= http://snapshot.opera.com/${MASTER_SITES_VER_PATH}/ \
http://T32.TecNik93.com/FreeBSD/others_ports/${PORTNAME}${PKGNAMESUFFIX}/sources/
@@ -42,7 +43,7 @@ ONLY_FOR_ARCHS= i386 amd64
.if ${OSVERSION} >= 700000
OPERA_TYPE= 7
-.else
+.else
OPERA_TYPE= 6
.endif
@@ -50,6 +51,10 @@ OPERA_TYPE= 6
LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/X11R6/lib/browser_plugins|${LOCALBASE}/lib/browser_plugins/symlinks/opera-devel|g' \
+ ${WRKSRC}/usr/local/share/opera/ini/pluginpath.ini
+
do-install:
@(cd ${WRKSRC} && ./install.sh --prefix=${PREFIX} --docdir=${DOCSDIR} --sharedir=${DATADIR} --exec_prefix=${DATADIR}/bin --plugindir=${DATADIR}/plugins)
@${CP} ${DATADIR}/bin/operapluginwrapper ${DATADIR}/bin/operapluginwrapper.freebsd