aboutsummaryrefslogtreecommitdiff
path: root/www/owncloud/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/owncloud/Makefile')
-rw-r--r--www/owncloud/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/www/owncloud/Makefile b/www/owncloud/Makefile
index 5c8cb69d4964..110277980ea6 100644
--- a/www/owncloud/Makefile
+++ b/www/owncloud/Makefile
@@ -11,12 +11,9 @@ COMMENT= Personal cloud which runs on your own server
LICENSE= AGPLv3
-BUILD_DEPENDS= mp3info:${PORTSDIR}/audio/mp3info
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-
USE_BZIP2= yes
-USE_PHP= bz2 ctype curl dom exif fileinfo filter gd hash iconv json \
- ldap mbstring openssl pdo session simplexml xml xmlreader \
+USE_PHP= bz2 ctype curl dom fileinfo filter gd hash iconv json \
+ mbstring pdo session simplexml xml xmlreader \
xsl wddx zip zlib
WANT_PHP_WEB= yes
@@ -29,12 +26,22 @@ SUB_FILES= pkg-message
PLIST_SUB= OWNCLOUD_USERNAME=${OWNCLOUD_USERNAME} \
OWNCLOUD_GROUPNAME=${OWNCLOUD_GROUPNAME}
+OPTIONS_DEFINE= EXIF LDAP MP3INFO SSL
OPTIONS_MULTI= DB
OPTIONS_MULTI_DB= MYSQL PGSQL SQLITE
-OPTIONS_DEFAULT= SQLITE
+OPTIONS_DEFAULT= EXIF LDAP MP3INFO SQLITE SSL
+
+EXIF_DESC= Image rotation support
+MP3INFO_DESC= MP3 ID3 tags support
+
+EXIF_USE= PHP=exif
+LDAP_USE= PHP=ldap
+MP3INFO_BUILD_DEPENDS= mp3info:${PORTSDIR}/audio/mp3info
+MP3INFO_RUN_DEPENDS= ${MP3INFO_BUILD_DEPENDS}
MYSQL_USE= MYSQL=client PHP=mysql,pdo_mysql
PGSQL_USE= PGSQL=yes PHP=pdo_pgsql,pgsql
SQLITE_USE= PHP=pdo_sqlite,sqlite3
+SSL_USE= PHP=openssl
do-install:
@${MKDIR} -m 0755 ${STAGEDIR}${WWWDIR}