aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-Clean2
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Apache-Clean2')
-rw-r--r--www/p5-Apache-Clean2/Makefile7
-rw-r--r--www/p5-Apache-Clean2/pkg-plist3
2 files changed, 5 insertions, 5 deletions
diff --git a/www/p5-Apache-Clean2/Makefile b/www/p5-Apache-Clean2/Makefile
index dc2009c16373..c3fb859c3df3 100644
--- a/www/p5-Apache-Clean2/Makefile
+++ b/www/p5-Apache-Clean2/Makefile
@@ -15,6 +15,7 @@ COMMENT= Mod_perl interface into HTML::Clean
BUILD_DEPENDS= ${APACHE_PKGNAMEPREFIX}mod_perl2>=0:${PORTSDIR}/www/mod_perl2 \
p5-HTML-Clean>=0.8:${PORTSDIR}/www/p5-HTML-Clean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}2
@@ -22,14 +23,12 @@ USES= perl5
USE_PERL5= configure
USE_APACHE= 22+
-MAN3= Apache::Clean.3
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-NO_STAGE= yes
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/www/p5-Apache-Clean2/pkg-plist b/www/p5-Apache-Clean2/pkg-plist
index 2ef7e3b83235..084ec8490e15 100644
--- a/www/p5-Apache-Clean2/pkg-plist
+++ b/www/p5-Apache-Clean2/pkg-plist
@@ -1,7 +1,8 @@
+%%PERL5_MAN3%%/Apache::Clean.3.gz
%%SITE_PERL%%/Apache/Clean.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Clean/.packlist
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Clean
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Clean
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache
@dirrmtry %%SITE_PERL%%/Apache