aboutsummaryrefslogtreecommitdiff
path: root/www/p5-AxKit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-AxKit/Makefile')
-rw-r--r--www/p5-AxKit/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/www/p5-AxKit/Makefile b/www/p5-AxKit/Makefile
index 838bfe277b1f..244e83b62db0 100644
--- a/www/p5-AxKit/Makefile
+++ b/www/p5-AxKit/Makefile
@@ -7,7 +7,7 @@
PORTNAME= AxKit
PORTVERSION= 1.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= xml/axkit
@@ -16,8 +16,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= XML Delivery Toolkit for Apache/Perl
-BUILD_DEPENDS= \
- ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
+RUN_DEPENDS= \
${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
${SITE_PERL}/${PERL_ARCH}/Apache/libapreq.pm:${PORTSDIR}/www/p5-libapreq \
${SITE_PERL}/${PERL_ARCH}/Apache/Test.pm:${PORTSDIR}/www/p5-Apache-Test \
@@ -29,7 +28,7 @@ BUILD_DEPENDS= \
${SITE_PERL}/Perl/Tidy.pm:${PORTSDIR}/devel/perltidy \
${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
MAKE_JOBS_SAFE= yes
@@ -67,6 +66,13 @@ CONFIGURE_ARGS= INC='-I${LOCALBASE}/include -I${LOCALBASE}/include/libxml2' \
CONFIGURE_ENV+= PERL_EXTUTILS_AUTOINSTALL='--defaultdeps'
PORTEXAMPLES= *
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
post-install:
.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}
@@ -74,4 +80,4 @@ post-install:
${CP} -R ${WRKSRC}/axkit.org ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>