aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI-Application-Plugin-Authentication/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-CGI-Application-Plugin-Authentication/Makefile')
-rw-r--r--www/p5-CGI-Application-Plugin-Authentication/Makefile31
1 files changed, 5 insertions, 26 deletions
diff --git a/www/p5-CGI-Application-Plugin-Authentication/Makefile b/www/p5-CGI-Application-Plugin-Authentication/Makefile
index c679e24c5769..8f2bc9b691d1 100644
--- a/www/p5-CGI-Application-Plugin-Authentication/Makefile
+++ b/www/p5-CGI-Application-Plugin-Authentication/Makefile
@@ -10,37 +10,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Support for authenticating requests in CGI::Application
-RUN_DEPENDS= p5-Apache-Htpasswd>=0:${PORTSDIR}/security/p5-Apache-Htpasswd \
+BUILD_DEPENDS= p5-Apache-Htpasswd>=0:${PORTSDIR}/security/p5-Apache-Htpasswd \
p5-CGI-Application>=4:${PORTSDIR}/www/p5-CGI-Application \
p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
- p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require
-BUILD_DEPENDS:= ${RUN_DEPENDS}
-BUILD_DEPENDS+= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
- p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken \
+ p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require \
+ p5-Color-Calc>=1.073:${PORTSDIR}/graphics/p5-Color-Calc
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-Warn>=0.11:${PORTSDIR}/devel/p5-Test-Warn
USES= perl5
USE_PERL5= modbuild
-MAN3= CGI::Application::Plugin::Authentication::Display.3 \
- CGI::Application::Plugin::Authentication::Display::Basic.3 \
- CGI::Application::Plugin::Authentication::Display::Classic.3 \
- CGI::Application::Plugin::Authentication::Driver.3 \
- CGI::Application::Plugin::Authentication::Driver::Filter::strip.3 \
- CGI::Application::Plugin::Authentication::Driver::DBI.3 \
- CGI::Application::Plugin::Authentication::Driver::Filter::sha1.3 \
- CGI::Application::Plugin::Authentication::Driver::Filter::lc.3 \
- CGI::Application::Plugin::Authentication::Store::Session.3 \
- CGI::Application::Plugin::Authentication.3 \
- CGI::Application::Plugin::Authentication::Driver::Filter::uc.3 \
- CGI::Application::Plugin::Authentication::Driver::Filter::crypt.3 \
- CGI::Application::Plugin::Authentication::Store.3 \
- CGI::Application::Plugin::Authentication::Driver::Generic.3 \
- CGI::Application::Plugin::Authentication::Store::Cookie.3 \
- CGI::Application::Plugin::Authentication::Driver::Authen::Simple.3 \
- CGI::Application::Plugin::Authentication::Driver::Filter::md5.3 \
- CGI::Application::Plugin::Authentication::Driver::HTPasswd.3 \
- CGI::Application::Plugin::Authentication::Driver::Dummy.3
-
-NO_STAGE= yes
.include <bsd.port.mk>