aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI-Simple/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-CGI-Simple/Makefile')
-rw-r--r--www/p5-CGI-Simple/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/www/p5-CGI-Simple/Makefile b/www/p5-CGI-Simple/Makefile
new file mode 100644
index 000000000000..e43c5f730b4d
--- /dev/null
+++ b/www/p5-CGI-Simple/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-CGI-Simple
+# Date created: 16 November 2004
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Simple
+PORTVERSION= 0.075
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/J/JF/JFREEMAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME:C/CGI/Cgi/}-${PORTVERSION}
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= A simple totally OO CGI interface that is CGI.pm compliant
+
+PERL_CONFIGURE= yes
+
+MAN3= CGI::Simple.3 \
+ CGI::Simple::Cookie.3 \
+ CGI::Simple::Standard.3 \
+ CGI::Simple::Util.3
+
+pre-configure:
+ @${FIND} ${WRKSRC} -name '*.orig' -delete
+
+.include <bsd.port.mk>