aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI-Untaint-date/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-CGI-Untaint-date/Makefile')
-rw-r--r--www/p5-CGI-Untaint-date/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/www/p5-CGI-Untaint-date/Makefile b/www/p5-CGI-Untaint-date/Makefile
new file mode 100644
index 000000000000..31890f279cb9
--- /dev/null
+++ b/www/p5-CGI-Untaint-date/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-CGI-Untaint-date
+# Date created: 18 Jun 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Untaint-date
+PORTVERSION= 1.00
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Validate a date
+
+BUILD_DEPENDS= ${SITE_PERL}/CGI/Untaint.pm:${PORTSDIR}/www/p5-CGI-Untaint \
+ ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
+ ${SITE_PERL}/${PERL_ARCH}/Date/Simple.pm:${PORTSDIR}/devel/p5-Date-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= CGI::Untaint::date.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>