aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Component-ACCEPT_CONTEXT/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Catalyst-Component-ACCEPT_CONTEXT/Makefile')
-rw-r--r--www/p5-Catalyst-Component-ACCEPT_CONTEXT/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Component-ACCEPT_CONTEXT/Makefile b/www/p5-Catalyst-Component-ACCEPT_CONTEXT/Makefile
new file mode 100644
index 000000000000..6aa7547902b8
--- /dev/null
+++ b/www/p5-Catalyst-Component-ACCEPT_CONTEXT/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: www/p5-Catalyst-Component-ACCEPT_CONTEXT
+# Date created: 26 April 2007
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Component-ACCEPT_CONTEXT
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Make the Catalyst request context available in Models and Views
+
+RUN_DEPENDS= p5-Catalyst-Runtime>0::${PORTSDIR}/www/p5-Catalyst-Runtime
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Component::ACCEPT_CONTEXT.3
+
+post-patch:
+ ${PERL} -pi -e '$$_="" if /auto_install|Test::More/' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>