aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Controller-RateLimit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Catalyst-Controller-RateLimit/Makefile')
-rw-r--r--www/p5-Catalyst-Controller-RateLimit/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/www/p5-Catalyst-Controller-RateLimit/Makefile b/www/p5-Catalyst-Controller-RateLimit/Makefile
index a02009b4aa43..2d1a29c87c7a 100644
--- a/www/p5-Catalyst-Controller-RateLimit/Makefile
+++ b/www/p5-Catalyst-Controller-RateLimit/Makefile
@@ -18,10 +18,15 @@ BUILD_DEPENDS= p5-Algorithm-FloodControl>=1.91:${PORTSDIR}/devel/p5-Algorithm-Fl
p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-WWW-Mechanize-Catalyst>=0:${PORTSDIR}/devel/p5-Test-WWW-Mechanize-Catalyst \
- p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
- p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
+ p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>